Yamaha Rhino Forum banner
1 - 16 of 16 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter · #1 ·
I took the kids for a ride around the block. Turned the corner to come home... Heard a "pop"and some dust/dirt come up from under the seat and then it felt like it was in neutral.... Reverse, high, & low all felt like it was in neutral. So it'll go into gear but just won't do anything but rev.

What does it sound like I did?

Hope something isn't seriously wrong.
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #3 ·
I didn't even try in 4 wheel
Drive. Just shut it down and pushed it in the garage.

I'll check the drive shaft now
 

·
Registered
Joined
·
3,239 Posts
If you are in gear and the motor revs but vehicle doesn't move there can be a few reasons why...some are far worse than others so just start by finding out if the one or both drive shafts are turning...
 

·
Registered
Joined
·
3,591 Posts
You say it shifts into gears and when you give it gas it doesn't move right? Just sounds like it revs? Sounds to me the CVT belt might have busted apart........when was the last time that was replaced?
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #6 ·
You say it shifts into gears and when you give it gas it doesn't move right? Just sounds like it revs? Sounds to me the CVT belt might have busted apart........when was the last time that was replaced?
Not sure... I just picked it up off a buddy last week.

It won't move in 4WD either. Drive shaft doesn't look like its spinning either.
 

·
Registered
Joined
·
3,591 Posts
You say it shifts into gears and when you give it gas it doesn't move right? Just sounds like it revs? Sounds to me the CVT belt might have busted apart........when was the last time that was replaced?
Not sure... I just picked it up off a buddy last week.

It won't move in 4WD either. Drive shaft doesn't look like its spinning either.
I would take the CVT cover off and see if the belt and the sheave is good. Doesn't hurt to look. If the belt is torn apart - it wont move - period.
 

·
Registered
Joined
·
3,239 Posts
That very well could have been what the pop was...if so we have the best belt for you in stock...

If it moves in 4wd it's not the cvt...or the wet clutch...

If the drive shafts turn in gear it's not the cvt...
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #9 ·
That very well could have been what the pop was...if so we have the best belt for you in stock...

If it moves in 4wd it's not the cvt...or the wet clutch...

If the drive shafts turn in gear it's not the cvt...
No movement in 4wd... Just revs.

Neither drive shaft appear to spin either.

Can you link me up to the cvt belt? I take its a more heavy duty?
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #11 ·
Belt was shredded... I just picked the rhino up a week or two ago, and it's an '06. Pretty positive it's the stock/original belt. Time for an upgrade.

Thanks for everyone's help.
 

·
Registered
Joined
·
5,892 Posts
call James at JBS (number in my sig) and get an OEM 700 belt. best belt outhere and he has the best prices on them.
 

·
Registered
Joined
·
3,591 Posts
You say it shifts into gears and when you give it gas it doesn't move right? Just sounds like it revs? Sounds to me the CVT belt might have busted apart........when was the last time that was replaced?
Belt was shredded... I just picked the rhino up a week or two ago, and it's an '06. Pretty positive it's the stock/original belt. Time for an upgrade.

Thanks for everyone's help.
Shazzam! Hit it right on the head. Those simpletons sounds like a shredded belt. Easy fix! Good luck with that fix man! :fing02:
 

·
Registered
Joined
·
252 Posts
I've ran across a few videos on the forum of doing a belt replacement. Seems the time consuming part is getting stuff out of the way to get to the CVT cover, then removing all the screws, once in the CVT its like a couple minute replacement job, then another 45 minutes to put all the screws back in and put all the bars, braces etc back in place.

Sure glad it was just a CVT belt, lots more expensive parts to replace otherwise.
 

·
Registered
Joined
·
82 Posts
K
call James at JBS (number in my sig) and get an OEM 700 belt. best belt outhere and he has the best prices on them.
Why a 700 belt? Will it hurt anything if I leave the cover off? Only ride in the dunes and on trails.
 

·
Registered
Joined
·
3,239 Posts
Because the Yamaha OEM 700 belt is Kevlar and the best kevlar belt made for the Rhino fits the 660 and 700 exactly the same...

If you buy an Yamaha factory belt for the 660 it is not a kevlar belt...

We sell have the 700 belt...

And currently running a sale on the hot rod sheave, od weights, cam plate, sliders, orange spring, and belt... all shipped anywhere in USA for $500...

First one to take the offer gets the deal...limited to one...
 
1 - 16 of 16 Posts
Top