Yamaha Rhino Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
3,228 Posts
Title of the thread misleading :)

It cranks and cranks but won't fire...

It is out of gas and pump is not re-priming...

Odds are the pump is dead but not necessarily...

Remove fuel line from carb and see if any gas pours out...

Then with spark plug grounded so it cannot fire...put line from pump into a cup...remove the filter from your air box...cover the hole with your hand...crank motor and see if the pump will pump gas into the cup...

If it does...reconnect line...crank to prime carb with hand over intake hole...then replace spark plug cap on plug...replace air filter...it should start...

That will tell you if your pump is dead...

My fuel kits are a lot more than just clear line and allow for lots of diagnostics...come in a variety of configurations...not all of which are shown on the website...and available with high volume vacuum operated fuel pumps...

pm me your email if you need more advice...
 

·
Registered
Joined
·
396 Posts
if it were me i would spray starting fuild in the intake by the shifter....if it fires mometarly and then dies....and will not restart?....spray again...if it still does it....you have a fuel problem.....then check gas in tank....pick-up....filter..pump...vacumm hose?
 

·
Registered
Joined
·
996 Posts
its probably the fuel pump. My father in law had the same problem. He replaced the fuel pump and now it runs great again.
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top