Yamaha Rhino Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
279 Posts
Discussion Starter · #1 ·
The rhino has been sitting for a while now. Been busy with work and school. Before it was sitting I removed all the gas. Well the wife decided she wanted to use it to do yard work. So I went out to the shop put gas in it and messed with it for a bit. Finally got it to crank over and start. It was idling and I walked up to the house to get the keys to the tractor. I heard it quit running. Didn't sound like it sputtered or anything. Just quit running. I went back down there and tried to start it again and nothing. It will turn over. I pulled the spark plug and it has spark. I can hear the fuel pump run when I turn the key or stop trying to crank it. All the fuses seem to be good. Not sure where to go from here. I need to replace the air filter. I took it out before I cranked it the first time. I'm thinking of trying a new spark plug. Any ideas why it would idle for about 3 minutes then die and not start again. I tried spraying starting fluid in the airbox under the hood. It just wants to continously turn over. Really doesn't even try to start. Any help would be appreciated. Thanks
 

·
Registered
Joined
·
42 Posts
Try a new plug before you dig any deeper......similar situation happened to me a few years ago. Make sure its OEM with proper gap.
 

·
Registered
Joined
·
279 Posts
Discussion Starter · #3 ·
I changed the plug out and ran through the diagnostics. It started up and I ran it around the neighborhood for a while. The real test will be today when I go try and start it again. Hopefully it'll crank up and run like its supposed to. My fault for letting it sit too long. Life just gets in the way some times. Thanks for your reply. I appreciate it.
 
1 - 3 of 3 Posts
Top