Yamaha Rhino Forum banner
1 - 20 of 28 Posts

·
Registered
Joined
·
172 Posts
Discussion Starter · #1 ·
who has done it? witch one did you get and why,what was the results? how hard was the install?
 

·
Registered
Joined
·
1,960 Posts
I just got the KMS sheave installed w/ a dunner's clutch kit. I will test it this weekend and report back. KMS installed it, but It is fairly easy to install. I had them install it because I wanted them to also install the dunners clutch kit.
 

·
Registered
Joined
·
1,246 Posts
That is the next mod I am going to do.

This is a good question for Mr. Offroad to answer for you sandbug.
 

·
Site Founder
Joined
·
7,894 Posts

·
Registered
Joined
·
172 Posts
Discussion Starter · #10 ·
well i took it off tonight and its wasted.i guess i was susposed to clean it or something.it was so full of dirt no wonder it wouldent go very fast.
 

·
Registered
Joined
·
4,106 Posts
who has done it? witch one did you get and why,what was the results? how hard was the install?
I installed the KMS Sheave, if you dont have doors on your Rhino its very easy to install. The hardest part for me was taking off my doors, and plastics to gain access to the sheave. I dont consider myself an adept mechanic at all... I have a decent set of tools but I actually dislike wrenching on stuff.

The results were a very improved top speed, also the engine felt like it was not working as hard in the 35-45 mph range... before going over 45 it seemed like the engine was winding-out but after the sheave I could easily get to 54 mph... my top speed right now with dynatek cdi and kms sheave is 57 mph on flat ground.

It is the best bang for the buck.

RhinoCrap also sells a sheave for less money.
 

·
Registered
Joined
·
172 Posts
Discussion Starter · #12 ·
it only took me 30 minutes to take it off. i got to call around tomorrow and see if anybody will sell me one without a core.i was hitting 51 and seems like one day i couldent go over 45.now i know why.
 

·
Life serves the risk taker
Joined
·
4,197 Posts
What do you mean by it being wasted? is it the stock one? What do you mean you were supposed to clean it?
 

·
Registered
Joined
·
4,106 Posts
sounds like you werent running a CVT filter on your Rhino. I would think that you might need to replace the V-belt too.

I recently installed my friends sheave and his was SUPER DIRTY inside... his grease was more like old cake batter.

I dont think your sheave is wasted unless its in pieces. Can you post any pics?
 

·
Registered
Joined
·
1,246 Posts
I am going to buy one this week. I would have loved to have one on over the weekend at the dunes. One word - Paddles!!! Damn what a difference they made!!!!
 

·
Registered
Joined
·
297 Posts
I am 15 years old with little mechanical experience and i did it by myself! Just haven't got to test it yet
 

·
Registered
Joined
·
172 Posts
Discussion Starter · #17 ·
i put a cvt filter the day i bought it. there is 2000 miles on it and i think i should have cleaned it or at least inspected it a 1000 miles ago.
here the corners are wore out and the sliders
 

·
Registered
Joined
·
1,960 Posts
1 - 20 of 28 Posts
Top