Yamaha Rhino Forum banner
1 - 20 of 25 Posts

·
Registered
Joined
·
67 Posts
Discussion Starter · #1 ·
Need some help---- if im going about 25 mph and i let off the gas it starts making a wierd noise it sounds like metal to metal on the brakes but its not that i checked---- im thinking maybe its the clutch or belt has anyone else had this proble?
 

·
Registered
Joined
·
4,106 Posts
I dont think its the clutch belt... if it was the belt you would notice a big flat spot under acceleration during different speeds.

Are you applying the brakes at all when it makes this noise?

Does it do this on the dirt or the street as well?
 

·
Registered
Joined
·
2,714 Posts
Mine does the samething.....but only when braking down hill. I was told it's clutch chatter and normal. Didnt believe it till I heard another Rhino do it. Its very strange if you ask me......
 

·
Registered
Joined
·
4,106 Posts
Mine does the samething.....but only when braking down hill. I was told it's clutch chatter and normal. Didnt believe it till I heard another Rhino do it. Its very strange if you ask me......
Mine also does what you are describing,... and I can tell you what caused it on my Rhino... I drove down the block with the parking brake on :guilty:, after that I noticed the sound when I braked hard or going downhill.
 

·
Registered
Joined
·
862 Posts
Need some help---- if im going about 25 mph and i let off the gas it starts making a wierd noise it sounds like metal to metal on the brakes but its not that i checked---- im thinking maybe its the clutch or belt has anyone else had this proble?
Didnt you just have that thing fixed, you need to hand over the keys to me!
 

·
Registered
Joined
·
231 Posts
I did the same thing. Took off with the parking brake on now the rear brake makes a different noise when braking mostly down hill. Do you think that the rotor is messed up or the pads are glazed. (I did that to mine more than once :p)
 

·
Registered
Joined
·
997 Posts
Is that what that thing is ??? a parking brake? I thought it had to be on for the rhino to go!!!! No wonder I'm not hitting 75MPH with a simple clutch sheave like everyone else says they get! lol. I thought my brakes sounded weird! LMAO
 

·
Registered
Joined
·
1,599 Posts
Need some help---- if im going about 25 mph and i let off the gas it starts making a wierd noise it sounds like metal to metal on the brakes but its not that i checked---- im thinking maybe its the clutch or belt has anyone else had this proble?
i've been told to adjust the engine brake....mine does the same. i've been told by town and rape-me that its normal. if they don't fix it when i take in for 6 month service i'm going to start rasing hell
 

·
Registered
Joined
·
67 Posts
Discussion Starter · #10 ·
Thats Normal!!!!

Yes. thats the noise im talking about let me know if anyone finds a fix to the problem... At least mine is not the only one doing it i thought it was another $2000 fix in my near future!!!!
 

·
Registered
Joined
·
67 Posts
Discussion Starter · #13 ·
yeah i call it my 90mph rule ---drive the **** out of it till it breaks jack it up and fix it and drive the **** out of it till it breaks again!!!!just turn the stereo up and the sound goes away!!!!
 

·
Registered
Joined
·
4,308 Posts
Hey guys I did the same thing and had the same noise. I pulled the rear brakes apart and 1 of the pads was completely missing ( the metal was there but no pad ). I just happened to catch it before it ruined a rotor.
 

·
Registered
Joined
·
67 Posts
Discussion Starter · #20 ·
who knows!!!

Hey guys I did the same thing and had the same noise. I pulled the rear brakes apart and 1 of the pads was completely missing ( the metal was there but no pad ). I just happened to catch it before it ruined a rotor.
Looked at my pads they apear to be good i think maybe the rotar is warped it almost sounds like its skipping. But it does sound like metal to metal---who know drive it till it breaks and then fix it i guess.........
 
1 - 20 of 25 Posts
Top