Yamaha Rhino Forum banner
21 - 25 of 25 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter · #21 ·
I'd start with the basics like replacing the thermostat, bleeding the air out of the coolant system, and installing a gauge to measure/monitor engine temp & fan operation.
I had burped the cooling system but got lazy and did not purge at the lower end. This time I opened the lower end and what appeared to be straight water came out. Not a lot but enough I had tgo add coolant to the system. While doing so the top of the reservoir fell into the frame and I cannot locate it so waiting on lid / top for it.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #22 ·
I cleaned the radiator very good and rode half dozen times no issue to night rode 30-40 min at 15-30 mph no issues.. Slowed to 4-5 mph for 20 minutes no issues back to 25 mph for 20 min. no issues. Let it idle for 10 min while I went in. Came out temp light on can hear water boiling and steam but cooling fan not running. I'm at my wits end HELP!!!!!!
I had burped the cooling system but got lazy and did not purge at the lower end. This time I opened the lower end and what appeared to be straight water came out. Not a lot but enough I had tgo add coolant to the system. While doing so the top of the reservoir fell into the frame and I cannot locate it so waiting on lid / top for it.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #23 ·
I'd start with the basics like replacing the thermostat, bleeding the air out of the coolant system, and installing a gauge to measure/monitor engine temp & fan operation.
I had burped the cooling system but got lazy and did not purge at the lower end. This time I opened the lower end and what appeared to be straight water came out. Not a lot but enough I had tgo add coolant to the system. While doing so the top of the reservoir fell into the frame and I cannot locate it so waiting on lid / top for it.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #24 ·
Check to make sure your coolant level is where it should be.
I had burped the cooling system but got lazy and did not purge at the lower end. This time I opened the lower end and what appeared to be straight water came out. Not a lot but enough I had tgo add coolant to the system. While doing so the top of the reservoir fell into the frame and I cannot locate it so waiting on lid / top for it.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #25 ·
I had burped the cooling system but got lazy and did not purge at the lower end. This time I opened the lower end and what appeared to be straight water came out. Not a lot but enough I had tgo add coolant to the system. While doing so the top of the reservoir fell into the frame and I cannot locate it so waiting on lid / top for it.
can a temp gauge be added?
 
21 - 25 of 25 Posts
Top