Yamaha Rhino Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi guys. First off, I'm new to the forum and looking for some help:) I've been lurking in the shadows for a few months now since I first got my rhino. Now then, I don't know much about this thing so bear with me. I do know its an 07 660, edelbrock carb, electric fuel pump, fmf, 2 in intake snorkel, and had a big 6 in gorilla lift (junk/ it's gone). Now then, I know the edelbrocks are junk, but I'm just trying to get the old girl running well enough to ride my wife and daughter around the neighborhood and hit a couple of mud holes on the weekends.
It cranks relatively easy, however I belive its idling a tad on the rich side. Whenever I give it over half throttle it completely falls on its face, and will die if I don't let off. Plug is soot black after this. I have called edelbrock and they've all but abandoned their product. I was finally able to get someone who knew about their carbs on the phone and he told me to click the needle all the way to the right (which was 14 clicks) then to click 14 to the left for the factory setting. From there left to lean, right to richen. Is this information correct? I tried 4 clicks to the left( one at a time with a test run in between) to no avail. Do I need a smaller main jet? Sorry for the story guys, but I'm not to sure about this electric fuel pump either(mr gasket)??? Also there is a vacuum hose attached to the intake manifold(in between carb and engine), can someone confirm if this goes to the old fuel pump? Any help would be greatly appreciated.
 

·
Registered
Joined
·
519 Posts
just on basics - in addition to the metering rod being out of proper adjustment it sounds like the diaphragm or spring is not functioning properly. There should be resistance in that process so the vacuum pulls the metering rod up gradually not all of a sudden, so that it will not fall on its face. Sorry I don't know the carb, that's just a basic to help you find the problem. Some carbs the vacuum works on a slide sometimes on a pot connected to the rod.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
Jim- I'm by no means a carb expert, how would I go about diagnosing a faulty spring?

Benzo-Lol, that's what I was expecting. You wouldn't know of anybody that has a factory carb would ya? I'm on a pretty tight budget.
 

·
Registered
Joined
·
1 Posts
I just installed electric fuel pump on my Rinno 660 , starts fine runs but .on my test run fuel comes out of 2 hoses that come off carb to open air ..,??????.I do have a tee on supply line from pump one to carb one return to tank ..van this be a float adjustment .no idea it eldebrock carb
 
1 - 6 of 6 Posts
Top