Yamaha Rhino Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
I just bought a 2007 rhino 450. It tops out at 28 mph. Does that sound right? When letting off the gas at WOT it back fires once or twice and sometimes wants to die. Only changes are a 2.5” snorkel hose out to the front and a new NGK Iridium plug. Any suggestions?
 

·
Registered
Joined
·
422 Posts
I just bought a 2007 rhino 450. It tops out at 28 mph. Does that sound right? When letting off the gas at WOT it back fires once or twice and sometimes wants to die. Only changes are a 2.5” snorkel hose out to the front and a new NGK Iridium plug. Any suggestions?

Not having owned a 450 I'm not sure what to expect out of them. I know a stock 700 is only good for around 38mph. You may have some sheave issues going on not allowing full travel on your drive belt. As for the back fire, maybe an exhaust leak near the head?
 

·
Super Lead Moderator
Joined
·
3,809 Posts
Welcome, if you search on here the snorkel may be your problem. If you ran the 2.5" straight to the carb you won't get enough air.
 

·
Super Lead Moderator
Joined
·
3,809 Posts
The snorkel is ran to the top of the air box. I left the air filter on the carb.
Did You re-jet the carb, you might be running to lean????
 

·
Registered
Joined
·
7 Posts
Discussion Starter #6
No I haven’t. Going to try to go through the carb this week. Also waiting for the cam plate and new weights for the clutch to come in to see if that helps
 

·
Registered
Joined
·
159 Posts
check the exhaust near the head for a crack. backfire on compression and slowing down is one of the symptoms.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #9
Took the whole exhaust off last night and it all looked good. It shoots a little flame out the back of the muffler when it backfires


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
422 Posts
Took the whole exhaust off last night and it all looked good. It shoots a little flame out the back of the muffler when it backfires


Sent from my iPhone using Tapatalk

Sounds like on decel you are dumping a little extra fuel into the exhaust, the heat is the ignition source and air coming in from somewhere completes combustion.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #11
Took the snorkel off tonight and still runs the same with the backfiring on decel.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
22 Posts
I have the same rhino 07 450 and the same snorkel and plug as you. I have a full roof and full glass windshield with a built up box enclosure on the dump box, so a fair bit of extra weight. I can get 50 plus km. out of it which would be 30 plus miles per hour. Lots fast enough for this old tiger to be going. I usually cruise 40 to 45 km. when on a flat road though.
Bruce aka 1 bad rhino
 
1 - 12 of 12 Posts
Top