Yamaha Rhino Forum banner

1 - 20 of 23 Posts

·
Registered
Joined
·
75 Posts
Discussion Starter #1 (Edited)
Starting to wire my R1 today and wondering if anyone has any tips to make this a little easier? What plugs are necessary and what should be bypassed? How big of a headache are these to wire up? Also has anyone used one of the Rossen Racing modified harnesses? Are they pretty much made where I can plug it in and go? I might consider that option if so.

Thanks
 

·
Registered
Joined
·
84 Posts
hey im doing an SV1000 swap right now and im having trouble with wiring. no fuel or spark. from what i researched alot of people are tieing together the clutch wire and sand stand switch. some are some bypassing the tip over sensor using a resistor. i think its a 60K or 120K something like that. hopefully that helps a little
 

·
Registered
Joined
·
1,045 Posts
R1 Wiring

R1 wiring:
-Bypass kickstand
-Bypass Clutch lever wires
-Mount Exup module or purchase bypass module
-I'd recommend leaving the tip sensor on and make a bracket for it
-Need resistor to keep low fuel indicator from blinking
-Tie in switches for ACC and Start
-Make sure all grounds, including body grounds, are tied in together
-There are two wires that go to the main switch that need to be grounded. The schematic in the service manual does not make this obvious. I couldn't get my motor running until WyattEarp (member) told me this. Locate the Blue/Yellow and Blue/Black wires and ground them.


That's all I can remember right now. I'm sure I'm forgetting something.
 

Attachments

·
Registered
Joined
·
84 Posts
"Locate the Blue/Yellow and Blue/Black wires and ground them."

i will look at mine and make sure thats not messing me up. For your harness are those two wires on a plug that is near the main switch?? if those arnt grounded, do you still get the motor to turn over?
 

·
Registered
Joined
·
1,045 Posts
My motor is a 2008. I don't have access to the Rhino this week so I cant check. But yes, the two wires are on the plug going to the main switch. If they are not grounded the engine will turn over, but it will not start. I was going crazy with this. If it wasn't for WyattEarp I would've torched the whole damn car!
 

·
Registered
Joined
·
1,045 Posts
Do you have a link for the service manual you can post? Either that or do you have a picture of the entire wiring schematic? I've never messed with the SV1000, but I'd like to try and help.
 

·
Registered
Joined
·
1,819 Posts
I kept as much of the stock harness as I could (for now), and only bypassed the things I needed to (like trucknuts stated above). I was able to do it with very little work on the harness, except for extending the wires to the gauge cluster. Ive got the resistor info for the low fuel sensor if you need it (PM me).
 

·
Registered
Joined
·
1,045 Posts
I kept as much of the stock harness as I could (for now), and only bypassed the things I needed to (like trucknuts stated above). I was able to do it with very little work on the harness, except for extending the wires to the gauge cluster. Ive got the resistor info for the low fuel sensor if you need it (PM me).
Is this on the SV1000 or the R1?
 

·
Registered
Joined
·
1,819 Posts
I kept as much of the stock harness as I could (for now), and only bypassed the things I needed to (like trucknuts stated above). I was able to do it with very little work on the harness, except for extending the wires to the gauge cluster. Ive got the resistor info for the low fuel sensor if you need it (PM me).
Is this on the SV1000 or the R1?
R1
 

·
Registered
Joined
·
1,819 Posts
The low fuel warning light can be bypassed by adding a 470 OHM 1/4 watt resistor inline with the wire coming from the gauges. On 03-06 this wire is Green with a white tracer.

GAUGES-------RESISTOR---------Ground

Just cut the wired somewhere down the line from the gauges, solder the resistor to the side going to gauges. Then solder a new wire to the other end of the resistor, and ground that wire. Tape off the unused end of the stock fuel level wire.
 

·
Registered
Joined
·
84 Posts
Okay so i tried putting it in dealer mode and it doesnt do anything. it still says CHEC. i tried it 3 times.

im using the stock ignition key and im getting 9V to the ECM. Still got nothing

i tried bypassing the tip over sensor with a resistor and still nothing.

i check to the fuel pump to see if the ECM was sending volts to it, 0.0V, nothing

double checked all grounds, nothing!

replace the two 30A started fuses and 15A ignition fuse, nothing!!

disconnected the gauge cluster, nothing!!!

grabbed my cell phone and threw it at the rhino, Nothing!!!!!! jk

when i say nothing i mean, no spark and no fuel, but its still rolling over.

starter relay does not click when i turn the key also, it should right??

would a faulty starter relay cause a no spark or fuel but still let the motor turn over???

i am beginning to think its the ECM.....crap
 

·
Registered
Joined
·
1,045 Posts
9 volts to the ECM? Shouldn't it be 12 volts?
 

·
Registered
Joined
·
84 Posts
the ignition has a diode/resister in it so that you can not hot wire it by just connecting all 4 wires. MX_racer is doing the same swap and he had to run a resistor since he does not have the oem ignition key switch. nothing will trigger if the ecm sees 12v on start up.
 

·
Registered
Joined
·
175 Posts
the ignition has a diode/resister in it so that you can not hot wire it by just connecting all 4 wires. MX_racer is doing the same swap and he had to run a resistor since he does not have the oem ignition key switch. nothing will trigger if the ecm sees 12v on start up.
yea this is correct i hadt to put a resistor between the orange red wire and the power wire commin to the ignition switch then i got spark and power to my fuel pump wire. i was haveing the exact same symptoms as him but my guage never said chec. me and sv1000 have been on the phone back and forth tryin to figure his porblem out and im just as stumped as him lol... on another note i did get mine to fire off this moring before work but i am gettin no fuel to my front cyl. so now i get to trace that problem im hopin there was trash in the rail from the motor sitting or just a bad injector.
 

·
Registered
Joined
·
1,819 Posts
Just doing a quick Google check (and not having a manual in front of me), this is what I found for the CHEC code.

"Bend yourself a paper clip, find the un-used connector in the tail section of the bike and put that ***** in dealer mode(bridge the two wires inserted into the connector)...get the code, look the code up on your computer, wam-bam fix the problem man..."

Is that what you did to try and get into dealer mode?

Also, this

"Yeah, CHEC isn't really that intuitive...

I've done it enough now to know what to check each time. Clutch in, kill switch set right, key on, kickstand up if it's in gear (you can start it in gear, as long as the stand is up) or kickstand can be down if it's in neutral."

Im sure youve already found all this, as it was the first hit on Google. But I feel like if you cant get it into dealer mode to confirm what the CHEC code is, and test everything, your going to be chasing your tail trying to figure this out..
 

·
Registered
Joined
·
84 Posts
yup, i found that same thread and tried putting it in dealer mode several times, making sure i was jumping the right wires.

made sure its in neutral, kickstand up, clutch in, kill switch in the run position.

same result every time.

would a bad fuel relay or bad starter relay cause it to roll over but not spark or pump fuel???
 

·
Registered
Joined
·
1,819 Posts
Not sure, but I wouldnt think so. Basically, the system looks at the Neutral Switch, Kickstand, Clutch and kill switch, and makes a decision wither or not to allow the motors to start. On a R1, this means not sending power to the Injectors (although the fuel pump will run, it will turn over, and there will be spark). Not sure how the SV does it.
 

·
Registered
Joined
·
84 Posts
"Neutral Switch, Kickstand, Clutch and kill switch, and makes a decision"

thats what i thought too, it looks likes its pointing to a bed ECM then, which is hard to believe, but o well, only one way to find out $$$.

thanks for all your help,
 
1 - 20 of 23 Posts
Top