Yamaha Rhino Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Power to meter When I hook up the power to turn it on the lights on my meter do not come on what my I look for ?
 

·
Registered
Joined
·
391 Posts
Power to meter When I hook up the power to turn it on the lights on my meter do not come on what my I look for ?
You need to assume that most of us are not in possession of a crystal ball, so try and give us just a tad bit more info on your issue at hand - like year/model and, as HighDez asked, what meter?
 

·
Registered
Joined
·
121 Posts
So it worked, then you installed a winch, and now it doesn't work. Is there absolutely nothing on the screen when the key is on or does it have some letters/numbers displayed?

Check for a blown fuse and also check the plug from the wire harness to the ECU to make sure it's still connected.
 

·
Registered
Joined
·
41 Posts
To continue with what HighDez started. If everything worked until you installed the winch then retrace your work. Did you leave something disconnected? Does the battery have 12+ volts? Is the ground (negative) good and tight? Bad grounds can cause a lot of problems and are easily overlooked. Does the winch function? Did something get reconnected improperly? Just asking basic questions that might lead you to the problem.Keep us updated.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #9
To continue with what HighDez started. If everything worked until you installed the winch then retrace your work. Did you leave something disconnected? Does the battery have 12+ volts? Is the ground (negative) good and tight? Bad grounds can cause a lot of problems and are easily overlooked. Does the winch function? Did something get reconnected improperly? Just asking basic questions that might lead you to the problem.Keep us updated.
To continue with what HighDez started. If everything worked until you installed the winch then retrace your work. Did you leave something disconnected? Does the battery have 12+ volts? Is the ground (negative) good and tight? Bad grounds can cause a lot of problems and are easily overlooked. Does the winch function? Did something get reconnected improperly? Just asking basic questions that might lead you to the problem.Keep us updated.
Thank you I will check this weekend ! It is at my cabin .
 
1 - 9 of 9 Posts
Top