Yamaha Rhino Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
I tried to use a 12volt air pump to put air in one of my tires with the 12volt power port on the dash and blew a fuse in seconds. My rhino is a 2008 and I cannot find the fuse to fix it. Can someone take a picture of the location?

thank you so much!!!
 

·
Registered
Joined
·
395 Posts
I tried to use a 12volt air pump to put air in one of my tires with the 12volt power port on the dash and blew a fuse in seconds. My rhino is a 2008 and I cannot find the fuse to fix it. Can someone take a picture of the location?

thank you so much!!!
On my 2012 all the fuses (that I'm aware of) are in the battery box under the hood.
 

·
Registered
Joined
·
395 Posts
On my 2012 all the fuses (that I'm aware of) are in the battery box under the hood.
On my 2012 all the fuses (that I'm aware of) are in the battery box under the hood.
Another thought is if you've checked the fuses and hey are good, then look for a connection issue right behind the power port - or damaged wire. Many of us have experience wire damage from rodents. For whatever reason they appear to like knawing on the insulation.
 

·
Registered
Joined
·
395 Posts
Another thought is if you've checked the fuses and hey are good, then look for a connection issue right behind the power port - or damaged wire. Many of us have experience wire damage from rodents. For whatever reason they appear to like knawing on the insulation.
One more thing (LOL) - sometimes the air compressor plug has a built-in fuse. At the end of the plug (that goes into the power port) see if you can unscrew it to reveal the fuse.
 
1 - 4 of 4 Posts
Top