Yamaha Rhino Forum banner
1 - 15 of 15 Posts

·
Registered
Joined
·
175 Posts
Discussion Starter · #1 ·
have 05 rhino and i cant get it into low range..the shifter just wont go into low with linkage hooked up or not cant get it in..any ideas? are my forks maybe bent or just not sliding on shift drum?
 

·
Registered
Joined
·
175 Posts
Discussion Starter · #6 ·
so..should i go ahead and tear my engine apart and see what sgoin on inside..really like to have my low range.. specially if im gonna put some 27 zillas on..who could i talk to about whats goin on?
 

·
Registered
Joined
·
175 Posts
Discussion Starter · #7 ·
is there anyway or place that i could look at shift drum and forks without spliting case? think ill have aproblem with zillas in high range?
 

·
Registered
Joined
·
102 Posts
Try loosening the brace around the front of the engine cover that connects under the seats and try it with them loose, mine got bent somehow, prob 7 yr old sitting on it. It wouldn't shift in low.
 

·
Registered
Joined
·
102 Posts
No the brace that goes from seat to seat, 14mm bolt I believe. Did you try unhooking the linkage and moving th lever on the motor by hand, without the linkage?
 

·
Registered
Joined
·
175 Posts
Discussion Starter · #11 ·
yep..goes little ways past high and stops..not a hard stop just a springy stop and wont go all way in too low range
 

·
Registered
Joined
·
282 Posts
yep..goes little ways past high and stops..not a hard stop just a springy stop and wont go all way in too low range
Im having somewhat of a similar issue..however I just rebuilt my motor. The shifter goes into L and the dash light comes on, but I can just hear belt belt free spinning and not engaging anything as if its in neutral.
 

·
Registered
Joined
·
282 Posts
exactly..mines doing that
I think I already figured mine out. I didn't realize that the gear that came out was the low gear..when you split the cases it just sort of falls out..I believe it was reinstalled backwords(once again..I didn't realize it was the low gear and had a blonde moment)

Looks like the motor is getting pulled back out...
 
1 - 15 of 15 Posts
Top