Yamaha Rhino Forum banner
1 - 20 of 47 Posts

·
Registered
Joined
·
960 Posts
Discussion Starter · #1 · (Edited)
no f****** way....

so i have 15.7 hrs on my new rebuilt rhino. and just now i was moving a unloaded trailer for my dad and it started smokin blue again.... and it smells horrible. i rode it easy for i think 9 hrs. then i gradually got back to normal ridin around 11. any thoughts on why it would do this with a fresh rebuild? its got new piston, rings, bore, crank, the whole deal. im $7000 deep in this POS and i literally cant get a single ride in without somethin goin wrong. i have $10 in savings now.
 

·
Registered
Joined
·
658 Posts
You had to drop an F bomb for the title?
 

·
Registered
Joined
·
5,840 Posts
dude go get a maverick 2013 left over for 12999 base model and have 5 times the power and a motor rated for over 30,000 miles lol
 

·
Registered
Joined
·
960 Posts
Discussion Starter · #4 ·
yep i did, sry but ive put everything ive got in this thing and its still fallin apart. ill never get another Rhino. couldnt pay me to get one. id get a maverick if i could afford it. imma try to get rid of this POS and get a truck. but i dont know why a new built motor would fail in 15.7 hrs
 

·
Registered
Joined
·
960 Posts
Discussion Starter · #5 ·
actually thats not a bad price. ive dumped 4k into this thing since July so by next summer i couldve bought a Maverick. dang, kinda interesting how cheap isnt really cheap lol
 

·
Registered
Joined
·
960 Posts
Discussion Starter · #8 ·
no, thanks polarblu.. Hunt's Cycle in Asheboro did it. he builds racing Rhinos and stuff, hes real good. and karma? wtf is that supposed to mean?
 

·
Registered
Joined
·
62 Posts
no, thanks polarblu.. Hunt's Cycle in Asheboro did it. he builds racing Rhinos and stuff, hes real good. and karma? wtf is that supposed to mean?
Then take it there?! If he's a builder worth anything he will make it right. Also with your other issues, why are you not getting his ideas on it? You sound like a basket case!
 

·
Registered
Joined
·
960 Posts
Discussion Starter · #10 ·
i did. he said everything was all good on it (ive been told that by Yamaha too) im gonna call him once his shop is open in the mornin.
 

·
Premium Member
Joined
·
7,795 Posts
Lol, this is a funny thread.....sad but funny, sorry to hear about your bad luck.......there are a ton of things that could be wrong but I'd bet, the machine shop or the piston installer or the guy who tuned it are to blame....or maybe a bad filterering air cleaner? Do some investigation and let us know what happend...
 

·
Registered
Joined
·
960 Posts
Discussion Starter · #12 ·
yea i guess it kinda would be from the perspective of somebody readin it lol. at polarblu im not tryna whine, id like to know if anyone has any ideas of what would cause this to happen with very low hours. which camshaw answered. when i was talkin about it bein a POS, i was rather pissed. wouldnt you be?
 

·
Premium Member
Joined
·
7,795 Posts
loose bore and or not properly fit rings,wrong timing, wrong grit hone on stone,dirt ingestion, improper ring break in process,bad guides or valvejob or seals, oil type used to build motor and used to break it in....there are a multitude of issues that can cause this.....
 

·
Premium Member
Joined
·
7,795 Posts
ps...dont buy a maverick, the maverick forum is like the polaris forum, all the members are on there defending all their broken parts and factory engineered issues....ask benzo, oh nevermind....he's still in denial....lol
 

·
Registered
Joined
·
960 Posts
Discussion Starter · #15 ·
ok thanks, does around 9 hrs driving under 25 sound ok for break in time? it was about 70% tank of gas
 

·
Registered
Joined
·
960 Posts
Discussion Starter · #16 ·
hahaha well maybe ill just get a beater jeep and chop it up then lol
 

·
Premium Member
Joined
·
7,795 Posts
if its low rpm with no load on the motor I would say you killed the rings/hone job....cylinder pressures seat rings!....if no pressure- caused by low rpm is all the rings were exposed too then you could have wiped all the coating/moly off the rings and it wont seat them....a realistic possibility...
 

·
Registered
Joined
·
960 Posts
Discussion Starter · #18 ·
there was a fair amount of pressure cause i kept goin up a real steep hill every prob 20 mins of regular drivin. and after the 9 hrs i got harder on it honesty. i rode with a friend of mine whos got a Honda 400ex so we stayed 35-45 most of that ride and that was a good 4 hrs. then the rest was my normal drivin, 25-30mph average, hills, just the regular stuff
 

·
Registered
Joined
·
1,017 Posts
I sure cant speak to what is wrong with the Rhino especially after the rebuild but I guess I am lucky.. Other than a bit snotty in cold weather starting or after it sits for a while but.. my 06 has been pretty dang good.. Perhaps I don't beat on it enough( not suggesting you do.. ) just . not sure.. ... some seem good .. some seem to be a PIA Sorry you are having problems
 

·
Premium Member
Joined
·
7,795 Posts
a rode hard and put away wet rhino is the worse car to buy....if the boots are torn and the guy has never serviced the clutch then most likely its a rats nest!....the rhinos are the easiest sxs to work on out there, nuts and bolts and a little electrical.....but there are tricks to all toys....for the more part, if yamaha had a xp1000 killer sxs everybody who owns a pooplaris would sell it to buy a yamaha product handsdown....they build good quality stuff....now that the standard is FI and 100 hp and 18" of travel its time for yamaha and honda to step up and knock pooplaris off the pedestal.
 
1 - 20 of 47 Posts
Top