Yamaha Rhino Forum banner
1 - 15 of 15 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter · #1 ·
I came across a deal on a 06 rhino that was to good to pass up so i bought it.

06 660 rhino with 1000 miles(not sure if thats about normal or what)
27 in mud lites with black itp wheels
warn winch
HID lights
car battery kit
hard top with cd player and 4 speakers.
aftermarket CDI box
Gorilla axles at all 4 corners

all for less than 4500..... dont think i did too bad
 

·
Registered
Joined
·
561 Posts
Congrats and Welcome!
 

·
Registered
Joined
·
3,487 Posts
Welcome to the forum !
 

·
Registered
Joined
·
90 Posts
I hear that jhawes is a pimp down here in the dirty south(GA) ! glad u finally got onto the forum ! I told u there was alot of useful info on here !
 

·
Registered
Joined
·
6 Posts
i am a newby also here, anybody know where i can get info about my 08 rhino 700 getting hot too quick. any help would be appreciated
 

·
Registered
Joined
·
90 Posts
check your cooling system it may have an air pocket if you have had any engine work done lately and if not then you need to check your radiator fins,might have dirt built up in them
 

·
Registered
Joined
·
90 Posts
Its in the tech section at the very top ,or u can search it in the forum
 

·
Registered
Joined
·
6 Posts
the radiator looks new, there has been no engine work at all, and i am not sure about an air pocket. i took the cap off and let it run and the fluid level is the same. even when it is 30 degrees out, the fan still comes on after just a few minutes of running. thanks for the pointers djcnova
 
1 - 15 of 15 Posts
Top