Yamaha Rhino Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter · #1 ·
Just bought a 06 660 rhino. When u put it in the low side it seams to go in and the light goes to the l but it does nothing it's like your in neutral the rhino don't move at all. High side and reverse is great. Any ideas guys and thanx on advance.
 

·
Registered
Joined
·
521 Posts
Take the shifter rod off and see if it will shift into the gears. if so then it is an adjustment issue. Adjust rod length with it unattached so it will slip on without binding.
 

·
Vendor
Joined
·
3,516 Posts
Just bought a 06 660 rhino. When u put it in the low side it seams to go in and the light goes to the l but it does nothing it's like your in neutral the rhino don't move at all. High side and reverse is great. Any ideas guys and thanx on advance.
Remove the shifter rod from the lever on the engine side, then manually put it in gear there, if it goes into low gear then put the rod back to it and adjust until it goes on in that place if that makes sense. Also have the shifter in low when you do it

Or remove the rod, see if it goes into low gear manually then if it does, manually put it back in neutral and shifter in neutral and adjust rod until it goes on.

Todd
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #7 ·
Bump for any more advice. How hard is splitting the case as I use mine for hunting pretty much every weekend and don't wanna start something I can't finish and have to load it up in pieces and take it to someone.
 

·
Registered
Joined
·
521 Posts
Major project- If you got to ask then probably should not attempt, no offense intended. Motor out, top end off, cylinder off, split, assess, new parts, back together correctly and back apart to check lash, atc.
 
1 - 8 of 8 Posts
Top