Yamaha Rhino Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
122 Posts
Discussion Starter #1
For a long time my 660 will every once in a while act like the ignition switch is bad and I get nothing when I hit the key. I carry a heavy wire with.me to cross over starter relay and it will start up. Then after driving around a bit shut it off and ignition switch starts working again. This only happened every once in a blue moon. I’ve since replaced the switch but it never fixed the problem.

When the problem has occurred in the past I tested wires on back of switch and it was putting out juice when turning key over. Also changed starter relay at same time and that had no effect.

Now here recently it is doing this almost every time I shut it off. What’s weird is if I hit the key immediately after shutting off it will turn over every time but if I let it set for 5 minutes the switch don’t work. After it has set for a few hours the switch then works again and after riding it 1/2 mile I shut it off let it set 10 minutes and nothing again.

Does this sound like s heat issue??

Does CDI box have anything to do with ignition switch not starting the machine?
 

·
Premium Member
Joined
·
3,131 Posts
Have you done the frame grounding mod yet?


Sent from my iPhone using Tapatalk
 

·
Super Lead Moderator
Joined
·
3,809 Posts
If you can borrow a stock CDI I would swap it out to see, I think the CDI controls the firing pulse.
 

·
Registered
Joined
·
122 Posts
Discussion Starter #5
If you can borrow a stock CDI I would swap it out to see, I think the CDI controls the firing pulse.
Well I’ve owned it about 9 years and it always had the black rhino CDI that was in it when I bought it.
That CDI just went bad so I put the stock CDI in it couple weeks ago which I was given when I purchased the rhino. Since then is when I started having this problem more frequently.
Also with stock CDI installed reverse light comes on and flashes when driving but it does not affect performance.

I know CDI is involved with timing and firing order but Does CDI control juice being sent to starter relay so motor will turn over???
 

·
Registered
Joined
·
122 Posts
Discussion Starter #8
Just fer grinns try working the shift linkage while trying to start it. Maybe not a good neutral position.
Tried that but it does not help.
It is still doing it. I Just drove it shut it off and it starts up 5 times in a row and then nothing on the 6th attempt.
Cross over starter relay and turns over fine.
 

·
Registered
Joined
·
33 Posts
Have you figured this problem out? Im having similar issues and im begining to think it has to do with the break ignition source....u know how u have to push the break in while you turn the key? I noticed when i turn the key and press the break and it doesnt start but when i go to turn the key in off position (while still holding the break in) it tries to turn over just slightly...its either the actual ignition switch or the break ignition source...whats your thoughts
 
1 - 9 of 9 Posts
Top