Yamaha Rhino Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
452 Posts
Discussion Starter · #1 ·
I'm out in the desert and got back from a ride yesterday and when I let off the throttle and the "engine braking" is on it makes a high pitched whining noise. Sounds like its coming from the clutch trans area. I'm not gonna tear into out here but thought I would ask what it might be. Is this a common thing? Belt? I've done the sheave and greaseless weights. Everything on the outside looks fine nothing obvious. Thanks for any suggestions.
 

·
Registered
Joined
·
452 Posts
Discussion Starter · #3 ·
Just want to be clear that this ISN'T the grinding type noise that is complained about when going down hill. It's a new noise that I have never heard out of any Rhino before. It does it only when I let off the gas and it's slowing down. It's not right I'm just looking for a starting point if anyone has had a similar issue.
 

·
Registered
Joined
·
164 Posts
One of my customers rhino had same problem we put a new belt on and used 500 grit to clean the sheaves and the noise went away . . . So u may want to look into that look at the belt real good to see if it's burnt . . .hope this helps.........

Brad
Paraprosracing.com.
 

·
Registered
Joined
·
452 Posts
Discussion Starter · #5 ·
One of my customers rhino had same problem we put a new belt on and used 500 grit to clean the sheaves and the noise went away . . . So u may want to look into that look at the belt real good to see if it's burnt . . .hope this helps.........

Brad
Paraprosracing.com.
That's where I was gonna start but thought I would post up to see if there was anyone with a similar problem and fix for it. Thanks for the suggestion.
Justin
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top