Yamaha Rhino Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hello! noobie here looking to get a good used Rhino as my family's first ATV. Found a nice one, looks to be in great shape from the pictures- but just came across an interesting discrepancy hoping someone may be kind enough to enlighten me on potential causes.
In looking at a picture of the dash of the 2008 Rhino I am interested in buying- the mileage reads 5076 but the hours read 44.6. I have not physically inspected it yet- bit of a drive, so want to make sure it's worth it. This ratio of hours to miles obviously isn't possible- I don't think. Under the miles section, the display says ODO and under the hours the display says HOURS- so I don't think this is a trip counter showing on the hours side- if that is even functionality that they have?
Any insight would be much appreciated. Everything else about the machine is great, and it doesn't appear to have any wear & tear- even got a pic of the VIN on the frame and matched it to a pic of the VIN on the title. Chance ECU was swapped- and it reset the hours but not mileage? Or maybe a defective odometer?
Thanks in advance!
65044
 

·
Registered
Joined
·
44 Posts
Hello! noobie here looking to get a good used Rhino as my family's first ATV. Found a nice one, looks to be in great shape from the pictures- but just came across an interesting discrepancy hoping someone may be kind enough to enlighten me on potential causes.
In looking at a picture of the dash of the 2008 Rhino I am interested in buying- the mileage reads 5076 but the hours read 44.6. I have not physically inspected it yet- bit of a drive, so want to make sure it's worth it. This ratio of hours to miles obviously isn't possible- I don't think. Under the miles section, the display says ODO and under the hours the display says HOURS- so I don't think this is a trip counter showing on the hours side- if that is even functionality that they have?
Any insight would be much appreciated. Everything else about the machine is great, and it doesn't appear to have any wear & tear- even got a pic of the VIN on the frame and matched it to a pic of the VIN on the title. Chance ECU was swapped- and it reset the hours but not mileage? Or maybe a defective odometer?
Thanks in advance!
View attachment 65044
Hello! noobie here looking to get a good used Rhino as my family's first ATV. Found a nice one, looks to be in great shape from the pictures- but just came across an interesting discrepancy hoping someone may be kind enough to enlighten me on potential causes.
In looking at a picture of the dash of the 2008 Rhino I am interested in buying- the mileage reads 5076 but the hours read 44.6. I have not physically inspected it yet- bit of a drive, so want to make sure it's worth it. This ratio of hours to miles obviously isn't possible- I don't think. Under the miles section, the display says ODO and under the hours the display says HOURS- so I don't think this is a trip counter showing on the hours side- if that is even functionality that they have?
Any insight would be much appreciated. Everything else about the machine is great, and it doesn't appear to have any wear & tear- even got a pic of the VIN on the frame and matched it to a pic of the VIN on the title. Chance ECU was swapped- and it reset the hours but not mileage? Or maybe a defective odometer?
Thanks in advance!
View attachment 65044
Is the LCD Burnt out showing the 100th hr digit? I would definitely ask has the LCD cluster been replaced. I'm in a 2008 with 2349 miles and 425.9 hrs.
65045
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
Is the LCD Burnt out showing the 100th hr digit? I would definitely ask has the LCD cluster been replaced. I'm in a 2008 with 2349 miles and 425.9 hrs. View attachment 65045
Thanks for the reference! I ended up getting it. took it to a shop, and had it inspected before buying. It's in perfect shape, and no way has 5k miles on it. Mechanic said he'd believe it has 44 hours, and closer to 500 miles. Between my test drive and the mechanic driving it around during inspection, we probably put about a half mile on it, but the odo ticked up another 8 miles!. So definitely something wrong with the calibration.
 

·
Registered
Joined
·
55 Posts
I was going to ask if you were sure that wasn't 507.6 miles because I'm certain they show tenths of a mile. Happy trails. I'm officially Rhinoless now. Sold mine and will not likely get anything else.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #6 ·
I was going to ask if you were sure that wasn't 507.6 miles because I'm certain they show tenths of a mile. Happy trails. I'm officially Rhinoless now. Sold mine and will not likely get anything else.
Thanks for the feedback! it sure seems like that should be the case- as everything about the machine looks like it should be at 500 miles, not 5000. but I did some basic research, and it doesn't sound like the decimal point exists in the odometer, but I don't know for sure. It's definitely not visible tho.
I have a feeling however the odo measures a mile is messed up- not sure if that's a digital or mechanical system, but i have taken it for a couple quick runs, and it has ticked up several miles, and I only drove it about 1/2 mile. Will do a true test soon- by marking 1 mile with my car's odo, then driving same distance with rhino to check accuracy.
 

·
Registered
Joined
·
507 Posts
Check the speed sensor
 
  • Like
Reactions: Max92025

·
Captain Zoom Sand Pirate
Joined
·
3,418 Posts
Are you sure it is not in KM mode? Instead of Miles.
 
1 - 9 of 9 Posts
Top