Yamaha Rhino Forum banner
1 - 18 of 18 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
06 Rhino 660

Drive belt and clutch Sheave keep spinning even while at an idle. When try to put into gear Rhino Jumps and engine dies. Any Suggestions? Clutch Sheave is Trinity Racing installed last year. Replaced Bearing in front of wet clutch and problem persists
 

·
Registered
Joined
·
1,640 Posts
06 Rhino 660

Drive belt and clutch Sheave keep spinning even while at an idle. When try to put into gear Rhino Jumps and engine dies. Any Suggestions? Clutch Sheave is Trinity Racing installed last year. Replaced Bearing in front of wet clutch and problem persists

Sounds like you installed the one way bearing backwards. When installed on the shoulder of clutch you should see the word "outside" on the bearing. Park the rhino on level ground and put it in forward gear with the engine off. Try to push the rhino forward. If the bearing is correct it will lock up to the crank and turn over the engine. If it freewheels, it is installed backwards.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #6 ·
RE:Idle

Was running fine. Haven't messed with Idle. Started to smell something and replaced the belt. Problem still existed so replaced the Bearing .Cage on tight and seated.
 

·
Registered
Joined
·
1,640 Posts
Tried suggestion with Rhino in Gear it does Crank the Motor. Where should I start next?
Ok, now try to push it backwards with the gear selector in forward gear. It should freewheel when being pushed backwards.
 

·
Premium Member
Joined
·
3,184 Posts
Those posts are from 2011 doubt they are even still around on the forum


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
5 Posts
Have had nothing but problems with one way bearing. On the the 3rd bearing now. First one I made mistake an put it in backwards. Now here the problem I have now. It will spin freely counter clockwise, until I tighten the outer case. Any help would be great
 

·
Super Lead Moderator
Joined
·
3,809 Posts
Have had nothing but problems with one way bearing. On the the 3rd bearing now. First one I made mistake an put it in backwards. Now here the problem I have now. It will spin freely counter clockwise, until I tighten the outer case. Any help would be great
You may have the belt in a bind between the primary sheaves, just loosen the nut and with the gearshift in neutral rotate counter clockwise and make sure the spreader bolts are removed from the secondary. The belt should level up as you turn the sheaves. Then retorque the nut.
 

·
Vendor
Joined
·
3,516 Posts
Have had nothing but problems with one way bearing. On the the 3rd bearing now. First one I made mistake an put it in backwards. Now here the problem I have now. It will spin freely counter clockwise, until I tighten the outer case. Any help would be great
Are you using yamaha brand bearings?

Rhino, I think he means tighten the engine cover up
 

·
Registered
Joined
·
5 Posts
Ok figured that part out. Clutch seems to be working correctly. I put a Jbs hot rod sheeve an orange secondary spring. Thought this was supposed to give me more lower end An tip end. But seems like it’s all wrapped out at 20 mph. Oh it’s 06 rhino 660
 

·
Premium Member
Joined
·
3,184 Posts
Did u try and call James? Since u put in his parts i would call him. Thats all i will say since there is bad blood between the two sites


Sent from my iPhone using Tapatalk
 

·
Vendor
Joined
·
3,516 Posts
Ok figured that part out. Clutch seems to be working correctly. I put a Jbs hot rod sheeve an orange secondary spring. Thought this was supposed to give me more lower end An tip end. But seems like it’s all wrapped out at 20 mph. Oh it’s 06 rhino 660
You have a installation error, did you have the OD weights laying down with the 45 degree facing down or standing up and the 45 facing up and out? The latter is the right way.
 
1 - 18 of 18 Posts
Top