Yamaha Rhino Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
Hey I love the site and man these Rhinos are fun. I got a 04 Rhino 660 and I need some maintence done. I went on my first ride and it idles good but stalled a lot. I'm thinking and hoping fuel filter. I cleaned the air filter before the ride.

What maintenance should I be doing? I think this Rhino sat for awhile. Anyone want to get rid of a stock exhaust? Now I have an aftermarket and it is loud.

I want to get a stereo going too.

Thanks for any help,
Kenny
 

·
Registered
Joined
·
559 Posts
Welcome! Congrats on the rhino!
 

·
Registered
Joined
·
1,131 Posts
Welcome from WV !!

If it has sat for a long time like you say...more than like old/bad gas is your problem. Before you start tearing anything apart, drain all the old gas and put in some fresh hi-test...pick up a can of seafoam, and pour in a splash... swap out the old filter as well. If it isn't gunked up too bad, that should get you going...if it doesnt, you need to pull the carb and clean it.
 

·
Registered
Joined
·
286 Posts
Welcome from FL ! !
 

·
Registered
Joined
·
3,228 Posts
Hey I love the site and man these Rhinos are fun. I got a 04 Rhino 660 and I need some maintence done. I went on my first ride and it idles good but stalled a lot. I'm thinking and hoping fuel filter. I cleaned the air filter before the ride.

What maintenance should I be doing? I think this Rhino sat for awhile. Anyone want to get rid of a stock exhaust? Now I have an aftermarket and it is loud.

I want to get a stereo going too.

Thanks for any help,
Kenny
Welcome Kenny,

While you are at it you should replace your filter for good measure for starters...

Check your spark plug condition...

You have aftermarket exhaust...regardless of whether you intend to keep it or not you need to make sure your jetting is good if you are going to keep running it as is...

Check your plug first...then see if the carb has ever been opened...and if so what's in it...

If you are getting good fuel delivery and don't have crap in your float bowl and your jetting and idle a/f are correct and your needle is stock and in the stock position then the problem would probably be a sticky float...
 

·
Registered
Joined
·
708 Posts
Welcome!!!
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top