Yamaha Rhino Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hey Gang. I'm a total newbie from Canada. I found this site looking for help in figuring out what is wrong with my Rhino. I see there's a lot of info here, so I'm going to take some time to look around before I start hounding you with questions.
 

·
Registered
Joined
·
74 Posts
welcome .just ask if we cant help we know someone who can
 

·
Registered
Joined
·
561 Posts
Welcome
 

·
Registered
Joined
·
1,018 Posts
welcome!!!!!!!!!!!!
 

·
Registered
Joined
·
3 Posts
Discussion Starter #8
I've found a few threads that sound similar to the problems I'm having, so I'm guessing I have a carb and/or fuel pump problem. (Rhino 660 not sure what year)

The rhino will run great for awhile and then start to sputter badly, backfire and then stall. I usually have to wait a couple of minutes before it will start again.

It seems to happen pretty consistently when I start to climb a hill or while climbing a hill, if I ease off on the throttle it sputters right away.

It has also happened on long flat ground runs...as soon as I come off the throttle it starts coughing and backfiring.

I'm a recovering City Boy, so I'm kinda naive with this type of stuff...any help would be appreciated.
 

·
Registered
Joined
·
647 Posts
First thing to check is your fuel return and vent lines. They are notorious for getting kinks. Sounds like fuel delivery issue to me.

Could be fuel pump as well. Or clogged fuel filter. Popping/sputtering on decel is usually due to lean condition.

Rutting Rhino (sponsor on here) has some clear fuel line kits for cheap, which can help diagnose fuel issues. But either way, sounds like fuel delivery is the problem. Could also be improperly adjusted carb bowl float.
 

·
Registered
Joined
·
708 Posts
Welcome!!!
 
1 - 12 of 12 Posts
Top