Yamaha Rhino Forum banner

1 - 20 of 73 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter #1
Have a built benchmark 686 motor and just installed a bronco clutch , wanted to know if anyone has a a combo thats works well , i only run are car in the dirt no sand , i want the the best over all around performance as well as top end . I have a 4 seater with doors and other weight in the car . Currently i have a white spring in the secondary and 10 weights in the bronco , i just don't want to buy a bunch of springs and not use them . Any help would be great . Thanks much ,
 

·
Registered
Joined
·
6,996 Posts
I have the same setup with 8 weights and run an orange spring with my Bronco. Out of the hole it's insane and top end is perfect. I run mine in the sand alot though but it see's al types of terrain.
 

·
Registered
Joined
·
33 Posts
Discussion Starter #3
Chris from Benchmark had me running a white spring on the old setup and the car ran about 62 , i have a orange spring laying around but didn't want to wast time installing it if it make the belt slip , Also have you been breaking any Belts ?
 

·
Registered
Joined
·
33 Posts
Discussion Starter #4
Also i am running the cover and need to keep it on , the clutch is way to loud for my wife and kids not to run the cover , i also have the whole car Dyno matted for sound and have a cover directly behind the seat for sound and heat making the car very quite . I heard about running a Boat blower on the belt cover as well . Chris said not to worry about it since i am not running in the sand , but i would rather be safe then sorry , since this is my wife's car .
 

·
Registered
Joined
·
301 Posts
New to the forum. Im I to assume a 686 or bigger motor will "lunch" the wet clutches.? I only run the sand with 7 paddle haulers in a light two seater and use synthetic oil and so far (low hours) not had any problem. What is the early failure symptoms. Thanks
 

·
Registered
Joined
·
33 Posts
Discussion Starter #6
Don't know but when i had my wet clutch setup from Chris at Benchmark i had no problems , i just wanted more launch response from the car and the dry clutch was the best solution .
 

·
Registered
Joined
·
6,996 Posts
Also i am running the cover and need to keep it on , the clutch is way to loud for my wife and kids not to run the cover , i also have the whole car Dyno matted for sound and have a cover directly behind the seat for sound and heat making the car very quite . I heard about running a Boat blower on the belt cover as well . Chris said not to worry about it since i am not running in the sand , but i would rather be safe then sorry , since this is my wife's car .
How do you run the CVT cover on the Bronco Clutch? Mine dosn't fit. Mt bronco clutch is barely louder than stock. Maybe a little more noticable at idle but that's it.

I run in the sand and run a fan on the clutch to cool it down. I also have 26" tires and a 4 seater. No belt breakage so far....:fingersx:
 

·
Registered
Joined
·
761 Posts
Have a built benchmark 686 motor and just installed a bronco clutch , wanted to know if anyone has a a combo thats works well , i only run are car in the dirt no sand , i want the the best over all around performance as well as top end . I have a 4 seater with doors and other weight in the car . Currently i have a white spring in the secondary and 10 weights in the bronco , i just don't want to buy a bunch of springs and not use them . Any help would be great . Thanks much ,
The launch factor is determined by your carb setup as well...Call Chris he setup the 686 so he will know the carb setup and the clutch setup better than anyone...what carb are you running?
 

·
Registered
Joined
·
33 Posts
Discussion Starter #12
Also i am running the cover and need to keep it on , the clutch is way to loud for my wife and kids not to run the cover , i also have the whole car Dyno matted for sound and have a cover directly behind the seat for sound and heat making the car very quite . I heard about running a Boat blower on the belt cover as well . Chris said not to worry about it since i am not running in the sand , but i would rather be safe then sorry , since this is my wife's car .
 

·
Registered
Joined
·
33 Posts
Discussion Starter #13
Chris from Benchmark had me running a white spring on the old setup and the car ran about 62 , i have a orange spring laying around but didn't want to wast time installing it if it make the belt slip , Also have you been breaking any Belts ?
 

·
Registered
Joined
·
33 Posts
Discussion Starter #15
made a small cover over the 2'' hole on the cover then i wrapped the hole thing in Dyno matt . Also Dyno matted the Motor cover and all plastic around the front of the motor .
 

·
Registered
Joined
·
6,996 Posts
I run in all types of terrain. You name it, my Rhino has seen it. I moved my oil cooler to under my seat and use the stock cooling fan to keep it cool and at the same time blow cool air on my Dry Clutch. Then upgraded the fan on the radiator to a 800 cfm.
 

·
Registered
Joined
·
33 Posts
Discussion Starter #20
don't have a problem with adding a blower fan seem pretty easy , where do you have the inlet to the cover and are you running the cvt fan with the blower at the same time ?
 
1 - 20 of 73 Posts
Top