Yamaha Rhino Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hi everyone, i have a 2009 rhino 700, i have been racking my brain and replacing every part i can think of but i cant seem to track down a rear end noise. The noise sounds like a popping, clicking noise when you turn certain ways, back up at times and even going forward. I have replaced both cv shafts, all bearings bushings ect., the rear driveshaft boss, even went as far as to replace an entire knuckle because there was still a slight bit of play after the bearings were replaced. The entire rear end is tight, i put bigger bolts in the diff housing there's no slop there. This is driving me crazy. Any input any ideas anything at all to go on would be amazing, i for the life of me cannot think of anything else to try. the rear diff fluid was as clean as the day i changed it no metal in it no chunks. Im at a total loss.
 

·
Registered
Joined
·
416 Posts
Hi everyone, i have a 2009 rhino 700, i have been racking my brain and replacing every part i can think of but i cant seem to track down a rear end noise. The noise sounds like a popping, clicking noise when you turn certain ways, back up at times and even going forward. I have replaced both cv shafts, all bearings bushings ect., the rear driveshaft boss, even went as far as to replace an entire knuckle because there was still a slight bit of play after the bearings were replaced. The entire rear end is tight, i put bigger bolts in the diff housing there's no slop there. This is driving me crazy. Any input any ideas anything at all to go on would be amazing, i for the life of me cannot think of anything else to try. the rear diff fluid was as clean as the day i changed it no metal in it no chunks. Im at a total loss.

How frustrating! I hope you can solve it soon. I'm sure this does not relate but I had a "rattle" noise coming from the back of the Rhino but fortunately it was nothing more than a loose heat shield. Good luck!
 
1 - 2 of 2 Posts
Top