Yamaha Rhino Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
671 Posts
Discussion Starter · #1 · (Edited)
So I had to cut my dune trip short due to the excessive oil blow by

I have a KMS siphon break (utv inc), K&N full Intake setup

First two days out it ran perfect then about half way through the third day after pulling wide open for some very long & steep hills I stopped to wait on the others & let it cool down a bit I noticed oil drips in the sand & looked under the rhino to find oil dripping from the skid plate.
Pulled the cover off and noticed excessive oil coming from the blow by filter dripping all over.
It still runs good, does not over heat or blow any smoke out the exhaust,but blowing oil bad.
I rigged a 16 oz. Gatorade bottle and stuck the filter in the bottle for a short quick run and it blew about 1/2" oil into the bottle.
When you just have it sitting at idle its good but if you rev it and hold for a few seconds you can see the oil rise into the break bottle.

Rings Shot?????????
 

·
Registered
Joined
·
5,840 Posts
when ur hi reving and holding u will see blow by just not sure how much is ok, lol

u dont have to much oil in there right
 

·
Registered
Joined
·
671 Posts
Discussion Starter · #3 ·
Checked the oil level after I noticed the blow by and it was very high???but it was good in the am before I went out. This was after an hour of being out duning After I got back to camp and let it sit it was showing nothing on the stick.
 

·
Registered
Joined
·
2,584 Posts
It will read higher when it is warm. Are you sure your Siphon Break hose isnt kinked causing the other vent to puke oil?
 

·
Registered
Joined
·
22 Posts
sorry to hear that, mine started to do the same thing, but i didnt have much blow by as you mentioned. got it back to camp and no oil on the stick. was out duning off gordons well, test hill, and patton valley. filled it back up with oil and it started to smoke out of the muffler, =(
time for a rebuild, who has good deal on complete rebuilds if anyone can chime in.
 

·
Registered
Joined
·
671 Posts
Discussion Starter · #6 · (Edited)
Other Vent???
I took the siphon break filter and hose off and cleaned it out with oil filter cleaner. put it back together and then rigged the Gatorade bottle dealeo to see just how much oil was blowing out. I know that a little hot oil looks like a large amount sometimes.
This picture is before the oil blow by to show what I've got. You could actually see the oil going up into the bottle when holding the throttle open for a couple seconds in neutral


It will read higher when it is warm. Are you sure your Siphon Break hose isnt kinked causing the other vent to puke oil?
 

·
Premium Member
Joined
·
7,795 Posts
x

you got the tank going to the wrong hose, it should be mounted off the other nipple and then u run the hose out towards the head and behind the seat,keeping the breather line running up hill so gravity always wants to drain back into the exspansion tank and then back into the crankcase, you have it running downhill and it will continue to puke its guts out all over the place that way, my brother in law had excessive PCV like you have and it was a broken piston,just a heads up, but reroute it first...
 

·
Registered
Joined
·
671 Posts
Discussion Starter · #8 ·
Will do on the tank
That's why I was thinking maybe a compression ring prob and that the oil ring was still good that's why no oil burning



you got the tank going to the wrong hose, it should be mounted off the other nipple and then u run the hose out towards the head and behind the seat,keeping the breather line running up hill so gravity always wants to drain back into the expansion tank and then back into the crankcase, you have it running downhill and it will continue to puke its guts out all over the place that way, my brother in law had excessive PCV like you have and it was a broken piston,just a heads up, but reroute it first...
 

·
Registered
Joined
·
5,892 Posts
yup turn it the other way like cam said...

after all weekend in glamis I lost about 1/2 qt, but I always check it in the AM.
 

·
Registered
Joined
·
5,840 Posts
It will read higher when it is warm. Are you sure your Siphon Break hose isnt kinked causing the other vent to puke oil?

i heard oil level will read low after its been ran cuz all the oil is still in the top end and coming down to the pan still,

after 20 minutes it should read perfect,
 

·
Registered
Joined
·
671 Posts
Discussion Starter · #12 · (Edited)
broken piston

broke the piston between the compression rings

other wise this thing still looks new, can still see the cross hatch in the bore
3400 miles & 245hrs
 

·
Registered
Joined
·
90 Posts
Damn,hate that ! Did u find that missing chunk anywhere? I hope u did ,that could cause major probs!my 07 is doin the same ,but not near as bad .makes me wonder ?good luck
 

·
Registered
Joined
·
671 Posts
Discussion Starter · #14 · (Edited)
Damn,hate that ! Did u find that missing chunk anywhere? I hope u did ,that could cause major probs!my 07 is doin the same ,but not near as bad .makes me wonder ?good luck
Yep, the piece was still in place, just removed it to take the pic
 
1 - 14 of 14 Posts
Top