Yamaha Rhino Forum banner
1 - 18 of 18 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter · #1 ·
let me see if this video works...
.......anyways, my rhino slowly devoloped a back fire at the intake.

it idles a few seconds then cuts off. it will idle with the choke on , with the choke on if you press the throttle and let off it revs really high for a second then idles back down.

i dont know what was previously on the rhino before i bought it about 8 months ago but as of now(the way i bought it) it has stock intake and stock exhaust.

today, i just replaced fuel filter,and spark plug and didnt notice any change. im guessing its all in the carb and maybe needs to be re-jetted or just cleaned not sure,that is why im posting here to get some advice.
 

·
Registered
Joined
·
45 Posts
Discussion Starter · #2 ·
in the video, it back fires under light acceleration. if im driving at least half throttle it will not do that and if i have no throttle it idles nice then just cuts off.
 

·
Registered
Joined
·
45 Posts
Discussion Starter · #4 ·
ok, cant seem to figure out how to upload a you tube video directly to the post so their is the link(above post).
 

·
Registered
Joined
·
7 Posts
mine was doing the the same but with no backfire.cleaned out carb jets were stopped up all most completely blocked off. know runs great. maybe this will help
 

·
Registered
Joined
·
357 Posts
My 06 does it all of the time when cold. When she is warmed up, no problem. Sounds just like mine. My old trx 400ex did the same thing pre-pipe and jetting and did it there after with the pipe and jetting change. That bike was really cold blooded.
 

·
Registered
Joined
·
581 Posts
Sounds like a clogged pilot jet or pilot circuit. Start by cleaning the carb and adding some fresh gas...Anytime the choke is required to maintain an idle that is the usual answer.

Nate
Alba Racing
 

·
Registered
Joined
·
230 Posts
I had the same exact problem. Replaced the pilot jet, problem solved. I tried cleaning the jet, but for some reason it just wouldn't work until I replaced it.
 

·
Registered
Joined
·
10 Posts
Clogged pilot jet. I've had two '06 660's with exact same problem. Fixed both by cleaning the pilot jet. Both now run smooth.
 

·
Registered
Joined
·
3,239 Posts
let me see if this video works... .......anyways, my rhino slowly devoloped a back fire at the intake.

it idles a few seconds then cuts off. it will idle with the choke on , with the choke on if you press the throttle and let off it revs really high for a second then idles back down.

i dont know what was previously on the rhino before i bought it about 8 months ago but as of now(the way i bought it) it has stock intake and stock exhaust.

today, i just replaced fuel filter,and spark plug and didnt notice any change. im guessing its all in the carb and maybe needs to be re-jetted or just cleaned not sure,that is why im posting here to get some advice.
Hey Kevin...how is it running now...and what did you do it...???
 

·
Registered
Joined
·
45 Posts
Discussion Starter · #18 ·
hey everyone,

would like to update everyone with good news,and for future users that are having the same problem.
After creating this thread I immediately received an email from Craig with RUTTING RHINO. he gave me a full page essay explaining his area of knowledge for this stuff relating to the problems I had. after several questions from me and hesitant thinking that my carb was fine cause I took it apart and cleaned it ,but still had the problem. I finally ordered the Jet kit from Craig who offered tons of help and information for easy installation.

I was also advised to order the Transparent fuel line kit,which when installed just looks cool and cleans up the engine compartment making everything really clean looking and it is very helpful on making sure your fuel is even getting past the fuel pump.

after ordering and Craig almost being late for work on several occasions just to make his customer happy and to simply offer help in 2 days I received all the parts and had them installed!!

with an old air filter I was thinking I need to order a new one and looked all over locally for one . with no luck finding one Craig once again offered a lot of help and offered me a great deal on his Custom intake kit with jets supplied.
I then received the filter 2 days later with detailed instructions sent by email. installation is very easy and cleans up the compartment very well.

once the filter was installed I then decided to fire up the rhino and WOW!! I was surprised just how well it idled. took it down the street and the don't remember a NEW rhino running this good.

All in all. if anyone is having this problem send Craig an email and order from him!
I have deal't with him several times and have never been let down. his parts are USA Quality made and made specifically for the application.
Service and Quality cant be compared to anything.

http://www.rhinoforums.net/ruttingrhino-com/57691-got-air-4.html

http://www.rhinoforums.net/ruttingrhino-com/58618-660-fuel-line-kit-stock-pump.html

http://www.rhinoforums.net/ruttingrhino-com/56450-jet-kit.html
these are the parts i used,and if anything order the intake kit. the volume of air it sucks in cant be compared to anything else with ease of installation.
sorry for the long post but Thanks for reading and thanks for the help! Kevin
 
1 - 18 of 18 Posts
Top