Yamaha Rhino Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
109 Posts
Would you take 200. and i'll come get it?
 

·
Registered
Joined
·
93 Posts
Hey Dan,
I installed the alternator this weekend and it is not charging and alternator is sparking inside itself. Any ideas what is wrong with it?
 

·
Registered
Joined
·
729 Posts
Discussion Starter · #7 ·
Hey Dan,
I installed the alternator this weekend and it is not charging and alternator is sparking inside itself. Any ideas what is wrong with it?
Seriously? I can call UTV Inc tomorrow and see if they have any idea what's going on. I'm really sorry about that....I will make sure you are taken care of one way or the other.
 

·
Registered
Joined
·
93 Posts
Hey Dan,
I installed the alternator this weekend and it is not charging and alternator is sparking inside itself. Any ideas what is wrong with it?
Seriously? I can call UTV Inc tomorrow and see if they have any idea what's going on. I'm really sorry about that....I will make sure you are taken care of one way or the other.

Ok, thanks Dan. I tried it one more time and not charging at all, and after running it for about 2 min is starts sparking inside and is very hot. Let me know what you come up with.
Thanks Kevin
 

·
Registered
Joined
·
91 Posts
Sounds like a bad alternator. Get a voltmeter and check it for output.

But the fact that it's hot suggests a bad armature, or bad internal grounding.
 

·
Registered
Joined
·
979 Posts
I had to ground out the mounting plate on mine to the frame. Its probably not the problem but did you do that on yours.
 
1 - 13 of 13 Posts
Top