Yamaha Rhino Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
54 Posts
Discussion Starter #1
Been running just fine since I pulled it outta winter storage back in late March. Always run with premium ethanol free fuel. Low time/ mileage, 250 hours, 2200 miles. It’s basically our lake Uber vehicle to get my bride down to the lake and back to the cabin, she’s 80 and poor health. Anyway, I parked it down at the lake, on a nose down incline for a couple hours. Go to back up the hill, banging, missing, backfiring. When I could get it relatively level it’d run ok. As so as I attempted to go up the incline, it’d damn near die, missing, backfiring. Plenty of fuel. Pulled the fuel filter, lotsa crud in it. Unless someone has another idea I’m guessing fuel related. I have the tank ready to come out. Just need to drain the fuel. I don’t have a Yamaha dedicated filter, I’m just gonna go with a generic. I assume that works. Now that it’s back on level ground, no problem, ran it down to the boat landing and back, didn’t miss a beat!
 

·
Registered
Joined
·
54 Posts
Discussion Starter #2
Been running just fine since I pulled it outta winter storage back in late March. Always run with premium ethanol free fuel. Low time/ mileage, 250 hours, 2200 miles. It’s basically our lake Uber vehicle to get my bride down to the lake and back to the cabin, she’s 80 and poor health. Anyway, I parked it down at the lake, on a nose down incline for a couple hours. Go to back up the hill, banging, missing, backfiring. When I could get it relatively level it’d run ok. As so as I attempted to go up the incline, it’d damn near die, missing, backfiring. Plenty of fuel. Pulled the fuel filter, lotsa crud in it. Unless someone has another idea I’m guessing fuel related. I have the tank ready to come out. Just need to drain the fuel. I don’t have a Yamaha dedicated filter, I’m just gonna go with a generic. I assume that works. Now that it’s back on level ground, no problem, ran it down to the boat landing and back, didn’t miss a beat!
got it all pulled apart. There was a noticeable difference just blowing thru the new filter vs old. Old would still pass air but took more oomph. There was nothing in the tank. Debris and bugs in the old filter. Hope that was it!
 
1 - 2 of 2 Posts
Top