Yamaha Rhino Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hey new to the forum and new to rhinos. I've always wanted one and now that I have one I'm pretty excited. The only thing is I bought this dead, got it for a really good deal though but all I had to do was change the oil pump which I had to take apart the crankcase to get to and I got it all put together and dropped back in. Got a new battery and went to go start it and it barely took will turn over, starter is in good shape I took it out and tested it and it works great and the starter relay ended up going out so I will have to get a new one but I bypassed it and it still won't start. I even jumped it and it still won't start it'll just crank real slow or just click or your hair it tried to spin but it won't go. Please need help any advice will help Im just anxious to get it going so I can ride it. Thanks in advance.
 

·
Registered
Joined
·
421 Posts
What was the reason for changing out the oil pump? Could it be the engine is bound up from previous lack of lubrication? What about a poor ground to the engine?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Well I changed it out cause where it meets the water pump it had twisted the broke the rod on both side water and oil shaft. But I figured it out now. I used liquid gasket maker for the crank cover gasket and it was rubbing the gears so it would spin, but I put an actual gasket on it and it works now.
 
1 - 3 of 3 Posts
Top