Yamaha Rhino Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have a 06 450 rhino I'm having issues Going past 25 miles an hour on flat ground I'm running oversized tires with the proper clutch kit from epi installed I've also installed a high flow fuel pump, Air filter kit, new drive belt, Rebuilt the card with a carb kit And re adjusted the valves According to the owner's manual. I am fresh out of ideas on what could be wrong with my machine can anybody give me a good idea I'm where to look next.
 

·
Premium Member
Joined
·
3,141 Posts
Is the rev light on when not going past 25


Sent from my iPhone using Tapatalk
 

·
Premium Member
Joined
·
3,141 Posts
25is the magic # on these rhinos, and it either the rev switch or the wireing fir the rev switch, when it tops out at 25 does it act like its hitting the rev limiter?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
Thanks all the rev limiter light is not on at 25 and it's acting like it's hitting the rev limiter.
 

·
Premium Member
Joined
·
3,141 Posts
I meant reverse light on the dash. When u put it in drive and ur driving does the reverse light on the dash stay on


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
13 Posts
My reverse light comes on and it acts like I hit the limiter but I am only doing 35km /hr. I can then go up to 50km /hr nothing happens. a while later it happens agin
 

·
Premium Member
Joined
·
3,141 Posts
My reverse light comes on and it acts like I hit the limiter but I am only doing 35km /hr. I can then go up to 50km /hr nothing happens. a while later it happens agin


Clean connector on top of reverse switch


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
2 Posts
OP, did you ever find the issue on your machine? My 450 is doing the same thing, and has the same parts yours does it sounds like. I can't figure it out..

Tried a new aftermarket CDI, and no change. Has new clutches, new belt, new battery, no lights on on the dash, and 21-22 mph is all it'll do before it hits a limiter and starts cutting out. Acts like it's in low range but it's not, shifting to low slows it considerably.

I'm at a loss. Hoping you fixed yours and can tell me what you did?

Sent from my SM-G970U using Tapatalk
 

·
Registered
Joined
·
159 Posts
i'm just going by memory but I think a flashing lite is a engine code. it is in the shop manual.
 

·
Registered
Joined
·
10 Posts
My 04 had same issue. On long trips with sustained higher speeds the reverse rev limit switch would fail and drop the top speed down to 25. I replaced three times before I got an aftermarket cdi that by passes the reverse rev switch.
 
1 - 12 of 12 Posts
Top