Yamaha Rhino Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
New to me carbureted 660: Smothers down at about 1/2 throttle with air filter installed. I removed the filter and it scoots without it. As far as I know, the engine is stock. I cleaned and oiled the filter, then washed the oil out thinking there was too much oil. I've read posts about re-jetting the carb, but I can't understand why it would be necessary. Any advice and explanations sincerely appreciated.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #2
Playing with it some more today.....With the air box lid on, I removed the 45 degree connector up to the engine cover. Now when the accelerator is floored I get a slight bog, then it revs on up. Put the connector back on and it falls on its face at about 1/2 throttle. Does that indicate the carb main jetting is too rich? I've not been into a Mikuni before and am sort of intimidated, so I don't know the current jetting. Being a utv just putting around the property, I could probably live with it, but finding a connector could be a problem. If these symptoms point strongly to the carb, I would dive into it. Advice appreciated.
 

·
Registered
Joined
·
59 Posts
Playing with it some more today.....With the air box lid on, I removed the 45 degree connector up to the engine cover. Now when the accelerator is floored I get a slight bog, then it revs on up. Put the connector back on and it falls on its face at about 1/2 throttle. Does that indicate the carb main jetting is too rich? I've not been into a Mikuni before and am sort of intimidated, so I don't know the current jetting. Being a utv just putting around the property, I could probably live with it, but finding a connector could be a problem. If these symptoms point strongly to the carb, I would dive into it. Advice appreciated.
Check the air box lid intake. Once I had dirt daubers completely block the intake on my big bear. it took a while to figure it out.
 
1 - 5 of 5 Posts
Top