Yamaha Rhino Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hey, First post here. I saw you guys and saw yall seem up to snuff with these rhinos. Let me run this by you, My 04' 660 is topping out at maybe 25mph. So far i have tried every trick I have found on this forum. Its not the backup switch or a gummed up primary sheave. I cleaned it and grounded the switch The belt is still in spec at 1.22''. Any ideas???
 

·
Registered
Joined
·
561 Posts
Welcome! With your cvt cover off and the rhino in N, have you gave it gas and made sure both clutches are working as the should?
 

·
Registered
Joined
·
14 Posts
Is the rev limiter coming up to soon ? If so it could be your CDI box , my 450 did this and I put the CDI off of my 660 on it and it went back to normal top speed (on 450) of 35.
 

·
Registered
Joined
·
3,239 Posts
How long have you had it...

Did it just start doing this...

Are you hitting the rev limiter...

What cdi is in it...

What was the top speed before...

What is the acceleration to 25...

You removed the primary and the grease and weights and tracks all look good right...

Hymarker is right...did you also check to see how high the belt goes on the primary sheave...

It should get up to within about 3/8" of the top of the primary sheave if it's a stock sheave with round rollers...

How did you verify it wasn't the reverse ground...

It is either ignition, fuel delivery, fuel metering, cvt not fully shifting out, or wet clutch is going out...
 
1 - 4 of 4 Posts
Top