Yamaha Rhino Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1 (Edited)
Guys, need some help here. My 05 Rhino fan is not working. I've looked at a ton of the posts' on rhinoforums and still cannot locate the Circuit Breaker (Radiator fan motor) that is discussed on the sites. the manual shows it being in the harness on the Drivers side of the Rhino. Many post refer to the Thermo Switch being on, or kind of behind the battery. I've found this one, but the manual says to check #4 circuit breaker first then move to the Thermal switch 3 in the radiator. Can someone send me a pick of where the circuit breaker is located? It appears to be in a clear cover and should only have two wires.

PS. Yes I've checked the fan and operates hooked up to battery.

Thanks
 

·
Registered
Joined
·
61 Posts
fan relay

Hello,
sorry can't help you track down the wires , haven't had that problem yet ..
have you considered just doing a toggle switch on the fan to just over ride the system ,,

TS2
 

·
Registered
Joined
·
12 Posts
Discussion Starter #3
I have thought about and have a switch, but wanted to make sure it was working properly. I did find it finally after unwrapping 1/2 the wiring harness. I was located above the steering column. Thanks for your help
 

·
Registered
Joined
·
121 Posts
Follow this video for trouble shooting and around the 12 minute mark is the circuit breaker for visual reference. Not exactly your machine, but the Grizzly 700 is similar to the Rhino 700 and all Yamaha's use a similar approach for the electrical systems....generally speaking.

Let us know how it goes.

 
1 - 5 of 5 Posts
Top