No spark, stator problem - Yamaha Rhino Forum - Rhino Forums.net
Engine For discussion of engine performance, and maintenance

 1Likes
  • 1 Post By Tobydlong
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 08-14-2019, 07:43 PM Thread Starter
Couch Potato
 
Tobydlong's Avatar
 
Join Date: Aug 2019
Posts: 9
No spark, stator problem

I traded a basket case four wheeler for a cobbled up mess rhino. I started with a new starter solenoid, now it cracks over. Everything I read led me to believe a cdi goes out often. Still no spark, but I feel better anyway. I got the meter out and started trouble shooting. (Thanks TINKEN). I got to the stator and it was a mess, the connections were laying in a mess of oily dirt. Pulse generator (pickup coil) failed and two of the lines are grounded to each other. I will buy a stator next. Anyone have any other advice while I am waiting on parts?
Attached Thumbnails
Click image for larger version

Name:	A53EF122-399C-471C-A47F-831B5F050B41_1565836809902.jpeg
Views:	11
Size:	1.61 MB
ID:	52870   Click image for larger version

Name:	FDD4AA74-E119-49A5-A608-B2BB3BBD7F93_1565836868921.jpeg
Views:	11
Size:	1.94 MB
ID:	52872  
Tobydlong is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 08-15-2019, 06:18 AM Thread Starter
Couch Potato
 
Tobydlong's Avatar
 
Join Date: Aug 2019
Posts: 9
I removed the stator and did some testing after it was removed. The stator showed 0.5 ohms across all 3 lines. Range is 0.32-0.43. Not that far off, is it? Pickup coil shows open line but should be between 459-561. That would make sense why I have no spark. Still waiting for parts. Any reason to remove the flywheel? The service manual is not that easy to follow, kinda jumps around a bit. Anything else I should look for while I’m in there? It actually looks pretty clean, I was pleasantly surprised. I took a picture and attached
Attached Thumbnails
Click image for larger version

Name:	5464872E-479E-46E9-A8FE-A2380068920B_1565874881627.jpeg
Views:	9
Size:	1.45 MB
ID:	52880   Click image for larger version

Name:	5508795B-AA15-45B5-8084-D78678835F6E_1565875064171.jpeg
Views:	10
Size:	1.51 MB
ID:	52882  
Tobydlong is offline  
post #3 of 3 (permalink) Old 08-20-2019, 04:12 AM Thread Starter
Couch Potato
 
Tobydlong's Avatar
 
Join Date: Aug 2019
Posts: 9
Got the new stator/piper coil installed. We have spark, and the engine is running
RHINO RAT likes this.
Tobydlong is offline  
Reply

  Lower Navigation
Go Back   Yamaha Rhino Forum - Rhino Forums.net > Technical > Engine

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Rhino Forum - Rhino Forums.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome