New To Me Rhino 660 - Temp Light & Won't Start Now - Yamaha Rhino Forum - Rhino Forums.net
Engine For discussion of engine performance, and maintenance

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 05-20-2019, 12:22 PM Thread Starter
Oil Spot
 
Join Date: May 2019
Posts: 24
New To Me Rhino 660 - Temp Light & Won't Start Now

Hello all! My first post here as I am looking for some help on the new to me Rhino. I suspect I will have a few more issues with this machine before I get all the bugs worked out. While in descent shape it will need some TLC on a few things to get it where I want it. I recently purchased this 2006 Yamaha Rhino 660 from a friend of a friend. His edlerly dad drove it around the farm and just recently passed away so he sold it. For the most part it has been as advertised. Right after purchase I took it to a dealer to have everything serviced and give it a good once over. It is a little hard to start after sitting several days but once started it runs strong and starts flawlessly everytime. I learned the fuel drains back after sitting for a prolonged period of time.


So anyway, this past weekend we drove it pretty much the entire day around the farm doing odd jobs. We started around 8am and used it around the farm all day until it finally died about 4:30pm. It was a hot one with temps right at 90 but not horrible. No heavy loads just normal stuff and driving around the farm - nothing hard. Around 3:30pm the temp light came on and it has never came on before for any reason. So we pulled it over and let it idle with the fan running a few minutes then turned it off for another 10mins while we did other stuff. It fired right back up and the light went off. About 20 minutes later the light came back on. Same deal we let it idle for a while and it went off. We kept driving it around and the light came back on and this time it died. The fan was running and it would crank after that but would not start. I checked the fuel to see if that might be part of the issue and it had 2-3" of fuel in the bottom of the tank window (no gauge in this one). I assume that would be enough fuel to start it back? Does anyone know if this model has a reserve tank/switch?


So a couple questions, not sure why it got hot as I thought it shouldn't be given it was light use? The overflow coolant tank has normal coolant level in it as I checked it. Not sure why it quite, nor why it wouldn't start back?
mcdenney is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 05-20-2019, 02:48 PM
Super Lead Moderator
 
RHINO RAT's Avatar
 
Join Date: Oct 2007
Location: VISALIA, CA
Posts: 3,804
Garage
Welcome to the site, no reserve tank switch on rhinos, when it's cold is it hard to start, if yes could be timing. Could be vapor lock make sure up by the carb you have the white tubing over the gas line it's to insulate the lines from heat. The hard start after sitting a few days is the fuel drains back into the tank search marine bulb install to help prime the fuel pump.

FLOYD, SANDI & Sadie is the co-pilot. 05 660, 3000# VENOM WINCH, LED headlight Mod, 12' led light bar RZR seats, Resi shocks, SunF 26 X 9r X 12, CUSTOM PAINT(the rescue chopper can find us know)

"REMEMBER, SPEED KILLS, BUT IT WILL BE THE ONLY TIME YOU'LL DIE LAUGHING"
RHINO RAT is offline  
post #3 of 6 (permalink) Old 05-20-2019, 02:52 PM
Site Supporter
 
Brian Lee Rhino450's Avatar
 
Join Date: Dec 2011
Location: Tuscola Texas
Posts: 3,002
New To Me Rhino 660 - Temp Light & Won't Start Now

For the starts after sitting a few days install a primer bulb like boats use to prime the system, several people on here use them, how does ur coolant look in the radiator?


Sent from my iPhone using Tapatalk

09 700 4seater, Nflow remanned motor with reverse upgrade, web cam, boared throttle body, duel muzzys with spark arrestors, MSDfuel controller. JBS Extreme2 sheave, SDR full radius cage, SDR doors, SDR long travel with summer brothers axles, Fox remote resi shocks with clickers on rears.
Brian Lee Rhino450 is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 05-21-2019, 06:06 AM Thread Starter
Oil Spot
 
Join Date: May 2019
Posts: 24
Thanks all to the replies! Great idea on the marine primer bulb! I will check that out and definitely add one.


I went back to the farm last night armed with a host of tools, etc to see if I could figure out what was going on. I wanted to check and see if the fuel level ( while low) was prohibiting from starting. She started up just like always with no temp light and ran like a top for over an hour. It restarted every time flawlessly. The coolant was perfect, but of coure I had all the fluids changed right after I bought it. The reserve coolant tank was filled properly as well. I checked the oil again and it seemed maybe a little low - towards the end of the dipstick but looked like brand new. I suspect the new filter took of up a little so that is why it was a fuzz low. Everything visually checked out. However, while we did use it all day I don't believe it should of gotten hot? And, whatever it was that caused it to get hot was what shut it down - if that is possible?


I need to try and figure it out as I don't want to constantly worry about it getting to hot and leaving me stranded on the farm while doing chores. It's not under a lot harsh conditions or heavy pulling so IMO it should not be getting that hot.


What other things can I check? I guess it is possible the temp sensor was in error? I checked the radiator and couldn't see a lot of dirt or debris. Also, what about the air filter? Could this impact it?
Thoughts?
mcdenney is offline  
post #5 of 6 (permalink) Old 08-17-2019, 08:11 AM
Hog Chaser
 
User Name's Avatar
 
Join Date: Feb 2019
Location: texas
Posts: 59
Garage
what type of coolant do i use for 2006 rhino 450?

Pete & Roberta
User Name is offline  
post #6 of 6 (permalink) Old 08-17-2019, 10:06 AM
Super Lead Moderator
 
RHINO RAT's Avatar
 
Join Date: Oct 2007
Location: VISALIA, CA
Posts: 3,804
Garage
I have Prestone 50/50 in mine. You can put in a electric temp gauge and know for sure.

FLOYD, SANDI & Sadie is the co-pilot. 05 660, 3000# VENOM WINCH, LED headlight Mod, 12' led light bar RZR seats, Resi shocks, SunF 26 X 9r X 12, CUSTOM PAINT(the rescue chopper can find us know)

"REMEMBER, SPEED KILLS, BUT IT WILL BE THE ONLY TIME YOU'LL DIE LAUGHING"
RHINO RAT is offline  
Reply

  Lower Navigation
Go Back   Yamaha Rhino Forum - Rhino Forums.net > Technical > Engine

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Rhino Forum - Rhino Forums.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in













Similar Threads
Thread Thread Starter Forum Replies Last Post
2004 Rhino 660 will not start Nate777 Engine 0 06-06-2018 03:16 PM
660 Temp light Rotaxxx Engine 3 04-05-2018 08:05 AM
2005 Rhino 660 Start and Die!! newtoutvs General Rhino Discussion 7 08-18-2017 10:16 AM
2005 Rhino Stalling and won't start crazynut52 Tutorials 4 06-11-2016 02:45 PM
07 Rhino 660 won't start Nnev Engine 9 01-28-2016 08:33 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome