Help Belt and Clutch Sheave keep spinning - Yamaha Rhino Forum - Rhino Forums.net
CVT, Sheaves and Wet Clutch A place to discuss troubleshooting and modifications.

 1Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 18 (permalink) Old 08-28-2011, 06:34 PM Thread Starter
Couch Potato
 
DannBre's Avatar
 
Join Date: Jun 2010
Posts: 8
Wrench Help Belt and Clutch Sheave keep spinning

06 Rhino 660

Drive belt and clutch Sheave keep spinning even while at an idle. When try to put into gear Rhino Jumps and engine dies. Any Suggestions? Clutch Sheave is Trinity Racing installed last year. Replaced Bearing in front of wet clutch and problem persists
DannBre is offline  
Sponsored Links
Advertisement
 
post #2 of 18 (permalink) Old 08-28-2011, 06:43 PM
Supernova
 
CamoRhino660's Avatar
 
Join Date: Feb 2010
Location: Hayesville,Ohio
Posts: 2,618
One way bearing in backwards??

Just happy to be riding again
CamoRhino660 is offline  
post #3 of 18 (permalink) Old 08-28-2011, 06:49 PM
Roo
Champion
 
Roo's Avatar
 
Join Date: Aug 2008
Location: So Cal
Posts: 1,640
Quote:
Originally Posted by DannBre View Post
06 Rhino 660

Drive belt and clutch Sheave keep spinning even while at an idle. When try to put into gear Rhino Jumps and engine dies. Any Suggestions? Clutch Sheave is Trinity Racing installed last year. Replaced Bearing in front of wet clutch and problem persists

Sounds like you installed the one way bearing backwards. When installed on the shoulder of clutch you should see the word "outside" on the bearing. Park the rhino on level ground and put it in forward gear with the engine off. Try to push the rhino forward. If the bearing is correct it will lock up to the crank and turn over the engine. If it freewheels, it is installed backwards.

Muzzy exhaust
Stage 2 HC
K&N Intake system
JBS sheave, 16gr. OD weight, and sliders
MSD Charge FI prototype (3D mapping)
Alba Racing dyno tuned
TCP oil cooler relocation kit
Roo is offline  
Sponsored Links
Advertisement
 
post #4 of 18 (permalink) Old 08-28-2011, 07:02 PM Thread Starter
Couch Potato
 
DannBre's Avatar
 
Join Date: Jun 2010
Posts: 8
Tried troubleshoot

Tried suggestion with Rhino in Gear it does Crank the Motor. Where should I start next?
DannBre is offline  
post #5 of 18 (permalink) Old 08-28-2011, 07:12 PM
Legendary
 
dbestduner's Avatar
 
Join Date: Feb 2011
Location: Apple Valley, CA
Posts: 5,892
idle too high. is your squirrel cage on tight and seated?

💩💩💩💩💩💩💩💩
dbestduner is offline  
post #6 of 18 (permalink) Old 08-28-2011, 07:19 PM Thread Starter
Couch Potato
 
DannBre's Avatar
 
Join Date: Jun 2010
Posts: 8
RE:Idle

Was running fine. Haven't messed with Idle. Started to smell something and replaced the belt. Problem still existed so replaced the Bearing .Cage on tight and seated.
DannBre is offline  
post #7 of 18 (permalink) Old 08-28-2011, 07:35 PM
Legendary
 
dbestduner's Avatar
 
Join Date: Feb 2011
Location: Apple Valley, CA
Posts: 5,892
Quote:
Originally Posted by DannBre View Post
Was running fine. Haven't messed with Idle. Started to smell something and replaced the belt. Problem still existed so replaced the Bearing .Cage on tight and seated.
hhmm if you give it gas in N do they move like normal?

💩💩💩💩💩💩💩💩
dbestduner is offline  
post #8 of 18 (permalink) Old 08-28-2011, 07:56 PM Thread Starter
Couch Potato
 
DannBre's Avatar
 
Join Date: Jun 2010
Posts: 8
Wrench Rhino troubleshoot

Yeah move like Normal when u give it gas in N.
DannBre is offline  
post #9 of 18 (permalink) Old 08-29-2011, 08:44 AM
Roo
Champion
 
Roo's Avatar
 
Join Date: Aug 2008
Location: So Cal
Posts: 1,640
Quote:
Originally Posted by DannBre View Post
Tried suggestion with Rhino in Gear it does Crank the Motor. Where should I start next?
Ok, now try to push it backwards with the gear selector in forward gear. It should freewheel when being pushed backwards.

Muzzy exhaust
Stage 2 HC
K&N Intake system
JBS sheave, 16gr. OD weight, and sliders
MSD Charge FI prototype (3D mapping)
Alba Racing dyno tuned
TCP oil cooler relocation kit
Roo is offline  
post #10 of 18 (permalink) Old 12-27-2018, 09:42 AM
Spectator
 
Join Date: Dec 2018
Posts: 1
Wondering if you found out the issue I’m currently having the same proplem and can not figure out what it is.
Jarrettg88 is offline  
post #11 of 18 (permalink) Old 12-27-2018, 01:42 PM
Site Supporter
 
Brian Lee Rhino450's Avatar
 
Join Date: Dec 2011
Location: Tuscola Texas
Posts: 2,885
Help Belt and Clutch Sheave keep spinning

Those posts are from 2011 doubt they are even still around on the forum


Sent from my iPhone using Tapatalk

09 700 4seater, Nflow remanned motor with reverse upgrade, web cam, boared throttle body, duel muzzys with spark arrestors, MSDfuel controller. JBS Extreme2 sheave, SDR full radius cage, SDR doors, SDR long travel with summer brothers axles, Fox remote resi shocks with clickers on rears.
Brian Lee Rhino450 is offline  
post #12 of 18 (permalink) Old 05-06-2019, 05:32 PM
Couch Potato
 
Join Date: Jun 2018
Posts: 5
Have had nothing but problems with one way bearing. On the the 3rd bearing now. First one I made mistake an put it in backwards. Now here the problem I have now. It will spin freely counter clockwise, until I tighten the outer case. Any help would be great
Kturner is offline  
post #13 of 18 (permalink) Old 05-06-2019, 08:14 PM
Super Lead Moderator
 
RHINO RAT's Avatar
 
Join Date: Oct 2007
Location: VISALIA, CA
Posts: 3,685
Garage
Quote:
Originally Posted by Kturner View Post
Have had nothing but problems with one way bearing. On the the 3rd bearing now. First one I made mistake an put it in backwards. Now here the problem I have now. It will spin freely counter clockwise, until I tighten the outer case. Any help would be great
You may have the belt in a bind between the primary sheaves, just loosen the nut and with the gearshift in neutral rotate counter clockwise and make sure the spreader bolts are removed from the secondary. The belt should level up as you turn the sheaves. Then retorque the nut.

FLOYD, SANDI & Sadie is the co-pilot. 05 660, 3000# VENOM WINCH, LED headlight Mod, 12' led light bar RZR seats, Resi shocks, SunF 26 X 9r X 12, CUSTOM PAINT(the rescue chopper can find us know)

"REMEMBER, SPEED KILLS, BUT IT WILL BE THE ONLY TIME YOU'LL DIE LAUGHING"
RHINO RAT is offline  
post #14 of 18 (permalink) Old 05-06-2019, 08:28 PM
Couch Potato
 
Join Date: Jun 2018
Posts: 5
Thank you I’ll try that tomorrow.
Kturner is offline  
post #15 of 18 (permalink) Old 05-07-2019, 04:46 AM
Official Site Vendor
 
Hunterworks's Avatar
 
Join Date: Jan 2009
Posts: 3,391
Quote:
Originally Posted by Kturner View Post
Have had nothing but problems with one way bearing. On the the 3rd bearing now. First one I made mistake an put it in backwards. Now here the problem I have now. It will spin freely counter clockwise, until I tighten the outer case. Any help would be great
Are you using yamaha brand bearings?

Rhino, I think he means tighten the engine cover up
Hunterworks is offline  
Reply

  Lower Navigation
Go Back   Yamaha Rhino Forum - Rhino Forums.net > Technical > CVT, Sheaves and Wet Clutch

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Rhino Forum - Rhino Forums.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome