2008 700 FI Fuel problem - Yamaha Rhino Forum - Rhino Forums.net
Tutorials How To Guides for Modifications, Bolt-Ons, Maintenance and Troubleshooting - Pictures make it better!

 
LinkBack Thread Tools Display Modes
post #1 of 13 (permalink) Old 10-02-2012, 05:33 PM Thread Starter
Spectator
 
Join Date: Oct 2012
Posts: 1
2008 700 FI Fuel problem

My rhino was running rough when you get on it and i replaced common things like spark plug and fuel filter. It seemed to help but now just doesnt run good all together. Any ideas?
JDavidson23 is offline  
Sponsored Links
Advertisement
 
post #2 of 13 (permalink) Old 10-02-2012, 05:40 PM
Black Magic
 
JRLoos's Avatar
 
Join Date: Sep 2011
Location: San Antonio/Houston, TX
Posts: 1,218
Maybe bad fuel...

2008 Rhino SE 700, custom 4-seat cage(built by me), full doors, all Twisted Stitch seats, Twisted Stitch rear 42" bench, Rigid Duallies, Rigid 20" E-Series LED Lightbar, Custom Bumper, Yeti Cooler, (2) White Whips, Alpine Tower Speakers w/ 400W Amp,Stage II Cam, Benchmark Throttle Body, Stock Exhuast w/ Tip, Dynatek Ignition Module, Power Commander V, Autotune, Hot Rod Sheave w/ weights, So Cal Long Travel, Kings, 27" Bighorns-Hiper Beadlocks, Billetking Rack, HCR HD Spindles
JRLoos is offline  
post #3 of 13 (permalink) Old 10-02-2012, 07:10 PM
Super Charged
 
Stuntmanmike's Avatar
 
Join Date: Apr 2012
Location: Crestview,FL
Posts: 895
Go into the self diagnostic function on the dash, It will tell you if you have any DTC'S, And you can look at real time data. And perform sensor test's.

05 Stroked 720cc. 09 700 ... Sheave,OD Sliders.http://youtu.be/4vM2BLqDKVshttps://youtu.be/hVR0R-wSxKY
Stuntmanmike is offline  
Sponsored Links
Advertisement
 
post #4 of 13 (permalink) Old 10-03-2012, 10:24 AM
Paper Boy
 
Join Date: Aug 2008
Posts: 18
Quote:
Originally Posted by JDavidson23 View Post
My rhino was running rough when you get on it and i replaced common things like spark plug and fuel filter. It seemed to help but now just doesnt run good all together. Any ideas?
Maybe you can help me out also. I've got an 08 700 rhino also. I have tried and tried to find the fuel filter and just can't locate it. My shop manual also don't show a fuel filter. Where is yours located? Thanks.....Sasakwa
Sasakwa is offline  
post #5 of 13 (permalink) Old 10-03-2012, 10:48 AM
Black Magic
 
JRLoos's Avatar
 
Join Date: Sep 2011
Location: San Antonio/Houston, TX
Posts: 1,218
Quote:
Originally Posted by Stuntmanmike View Post
Go into the self diagnostic function on the dash, It will tell you if you have any DTC'S, And you can look at real time data. And perform sensor test's.
How do you do this?

2008 Rhino SE 700, custom 4-seat cage(built by me), full doors, all Twisted Stitch seats, Twisted Stitch rear 42" bench, Rigid Duallies, Rigid 20" E-Series LED Lightbar, Custom Bumper, Yeti Cooler, (2) White Whips, Alpine Tower Speakers w/ 400W Amp,Stage II Cam, Benchmark Throttle Body, Stock Exhuast w/ Tip, Dynatek Ignition Module, Power Commander V, Autotune, Hot Rod Sheave w/ weights, So Cal Long Travel, Kings, 27" Bighorns-Hiper Beadlocks, Billetking Rack, HCR HD Spindles
JRLoos is offline  
post #6 of 13 (permalink) Old 10-03-2012, 10:58 AM
Super Charged
 
Stuntmanmike's Avatar
 
Join Date: Apr 2012
Location: Crestview,FL
Posts: 895
You will need the yamaha shop manual for the diagnostics, it will guide you thru it completely. The filter on the 700 is on the bottom of the fuel pump inside the gas tank.

Rhino Trail Phone. tapatalk

05 Stroked 720cc. 09 700 ... Sheave,OD Sliders.http://youtu.be/4vM2BLqDKVshttps://youtu.be/hVR0R-wSxKY
Stuntmanmike is offline  
post #7 of 13 (permalink) Old 10-03-2012, 10:59 AM
Paper Boy
 
Join Date: Aug 2008
Posts: 18
Thanks for the info.........Sasakwa
Sasakwa is offline  
post #8 of 13 (permalink) Old 10-03-2012, 01:18 PM
Slow Poke
 
Fatherof5's Avatar
 
Join Date: May 2012
Location: SW Florida
Posts: 36
I just had the same issues with mine and it turned out to be bad gas. Ended up draining the fuel tank and putting fresh gas in it and she runs like new again. It does not take much water in the fuel to cause the rhino to run poorly or even run at all in my case.
Fatherof5 is offline  
post #9 of 13 (permalink) Old 10-03-2012, 01:27 PM
Super Charged
 
Stuntmanmike's Avatar
 
Join Date: Apr 2012
Location: Crestview,FL
Posts: 895
That is o so true.

Rhino Trail Phone. tapatalk

05 Stroked 720cc. 09 700 ... Sheave,OD Sliders.http://youtu.be/4vM2BLqDKVshttps://youtu.be/hVR0R-wSxKY
Stuntmanmike is offline  
post #10 of 13 (permalink) Old 10-03-2012, 01:31 PM
Paper Boy
 
Join Date: Aug 2008
Posts: 18
I'm not actually having any fuel problems with my 700. It's just that common sense tells me to change the fuel filter but to date I have never found it nor have I found it mentioned in the shop manual. I just looked at the breakdown of my fuel pump inside the gas tank and my shop manual does not show a filter. I bought my Rhino new in 2008 and have never found a fuel filter nor have I found a grease zert and Lord knows I've looked..
Sasakwa is offline  
post #11 of 13 (permalink) Old 10-03-2012, 04:30 PM
Ripsaw
 
mtoma's Avatar
 
Join Date: Feb 2009
Location: Jackson, CA
Posts: 1,374
Quote:
Originally Posted by Sasakwa View Post
I'm not actually having any fuel problems with my 700. It's just that common sense tells me to change the fuel filter but to date I have never found it nor have I found it mentioned in the shop manual. I just looked at the breakdown of my fuel pump inside the gas tank and my shop manual does not show a filter. I bought my Rhino new in 2008 and have never found a fuel filter nor have I found a grease zert and Lord knows I've looked..
There's only a screen on the bottom of the fuel pump. No fuel filters on the FI models.



08 700, UTV Inc. Radius Cage, Lonestar Mid-travel, Fox DSC's
HotCams Stage II, MSD 3D, 11:1 CP, +1 valves, 46mm TB, Benchmark Performance Head,
Muzzy's, UNI Filter, JBS Sheave, 14g Greaseless OD, Gold Spring, Uni-Steer Power Steering, Rackzilla, Trinity Spindles
mtoma is offline  
post #12 of 13 (permalink) Old 10-04-2012, 05:26 AM
Paper Boy
 
Join Date: Aug 2008
Posts: 18
Thanks for clearing that up for me..Have a wonderful day.......
Sasakwa is offline  
post #13 of 13 (permalink) Old 11-02-2012, 09:34 AM
Slow Poke
 
Melroth's Avatar
 
Join Date: Sep 2010
Location: Yuma, AZ 85365
Posts: 33
I just had the same problem.I thought the engine was going to fall out almost. Figured it was the MSD. Changed that out but still was not right. I added fuel Sta-Bil fuel stabilizer and Heet Injector cleaner into thew gas. It smoothed everything right out. Could not believe it. Don't know if I had bad gas or what. No matter it's working now.
Melroth is offline  
Reply

  Lower Navigation
Go Back   Yamaha Rhino Forum - Rhino Forums.net > Technical > Tutorials

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Rhino Forum - Rhino Forums.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome