noise when in reverse - Yamaha Rhino Forum - Rhino Forums.net
Tutorials How To Guides for Modifications, Bolt-Ons, Maintenance and Troubleshooting - Pictures make it better!

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 06-12-2011, 07:48 AM Thread Starter
Veteran
 
mule deer hunter's Avatar
 
Join Date: Apr 2011
Location: Arizona
Posts: 472
AZ noise when in reverse

When I put my rhino in reverse it has a loud squealing noise coming from transmission area it does it worse when trying to back up a hill. It only does it part of the time. And it only does it in reverse is it the belt or what? Any ideas would be a help.

2007 camo rhino 660, Fox 2.0 shocks, Black rhino cdi box, Itp rims, 26 inch Terra cross tires, Ipod hook up, Exaust tip, Four seat cage, Aluminum top, Leg minders, JBS hot rod sheave, cam plate, 700 belt, 16 gram weights, sliders, orange secondary spring, 2 4 inch trail tech hids, Rutting Rhino air intake,Rutting Rhino jet kit, Rutting Rhino fuel delivery kit
mule deer hunter is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 06-12-2011, 08:35 AM
Clowning Around
 
WV Hot Rod Rhino's Avatar
 
Join Date: Aug 2010
Location: Mt. Hope, WV
Posts: 835
660?? brakes
WV Hot Rod Rhino is offline  
post #3 of 4 (permalink) Old 06-12-2011, 08:58 AM Thread Starter
Veteran
 
mule deer hunter's Avatar
 
Join Date: Apr 2011
Location: Arizona
Posts: 472
Yes it is 660 do you think it is brakes? If so how can I correct it?

2007 camo rhino 660, Fox 2.0 shocks, Black rhino cdi box, Itp rims, 26 inch Terra cross tires, Ipod hook up, Exaust tip, Four seat cage, Aluminum top, Leg minders, JBS hot rod sheave, cam plate, 700 belt, 16 gram weights, sliders, orange secondary spring, 2 4 inch trail tech hids, Rutting Rhino air intake,Rutting Rhino jet kit, Rutting Rhino fuel delivery kit
mule deer hunter is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 06-12-2011, 01:28 PM
Legendary
 
benzo's Avatar
 
Join Date: Mar 2010
Location: Phx,AZ
Posts: 5,840
the 1 rear ebrake allways makes nasty noise , backing up

clean it , or u can try to drive a lil bit with the ebrake up to clean disc
benzo is offline  
Reply

  Lower Navigation
Go Back   Yamaha Rhino Forum - Rhino Forums.net > Technical > Tutorials

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Rhino Forum - Rhino Forums.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome