Rhino went dead - Yamaha Rhino Forum - Rhino Forums.net
Tutorials How To Guides for Modifications, Bolt-Ons, Maintenance and Troubleshooting - Pictures make it better!

 
LinkBack Thread Tools Display Modes
post #1 of 11 (permalink) Old 09-17-2009, 07:46 AM Thread Starter
Paper Boy
 
Join Date: Sep 2009
Posts: 16
Rhino went dead

Today I simpl added some coolant to my 05 rhino 660 backed it out of my barn. It conked out and wouldn't even turnover from there on. What do I do? I have a trail ride saturday
stefan07rhino is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 09-17-2009, 09:05 AM
Rocket
 
dhc-6's Avatar
 
Join Date: Dec 2007
Location: Eloy,AZ
Posts: 810
When my battery went dead on my 700 I could jump it and get it running but as soon as I tried to put it into gear it would die and would not turn over....The battery was fine the night befor but dead the next morning...**** happens!!!!
dhc-6 is offline  
post #3 of 11 (permalink) Old 09-17-2009, 09:06 AM
Super Charged
 
western196611's Avatar
 
Join Date: Mar 2009
Location: Central Kansas
Posts: 968
I would start out by checking the battery. Can you hear the silinod (Spelling)click?

2008 Polaris RZR 800, long travel kit, Rhino brand axles, Offset A-arms, XP shocks, New front differential with billet cage, PA doors, Super ATV 4500 pound winch.
western196611 is offline  
Sponsored Links
Advertisement
 
post #4 of 11 (permalink) Old 09-17-2009, 10:54 AM
Fabled
 
07fj's Avatar
 
Join Date: Oct 2007
Location: Ramona, Ca
Posts: 6,804
Quote:
Originally Posted by stefan07rhino View Post
Today I simpl added some coolant to my 05 rhino 660 backed it out of my barn. It conked out and wouldn't even turnover from there on. What do I do? I have a trail ride saturday
would not turn over or would not start, when rhino's set for a while the gas in the bowl can dry out, takes a while to prime the pump and get gas to the bowl again.

if does not turn over then jump start it and see what happens, I suggest a good charge before you go and/or bring jump cables just in case the batt is going bad.


Rog



LOORRS Rookie of the Year
Unlimited UTV 2009

Benchmark 686, (67.6 RWHP )
HRT Motorsports cage, LSR XTR 6.5
Rugged RRP600
www.unleashedutv.com
07fj is offline  
post #5 of 11 (permalink) Old 09-17-2009, 04:29 PM
Experienced
 
660Rhino's Avatar
 
Join Date: Apr 2009
Location: GP, Alberta
Posts: 546
If there is no power at all, check the ignition fuse under the battery cover, clean battery posts, general wire check.

I don't recommend charging a battery while the ground is still connected because it can and has in the passed fried the digi dash. And as 07fj mentioned a good charge to see if it will start before any boosting.
660Rhino is offline  
post #6 of 11 (permalink) Old 09-17-2009, 04:42 PM
Enjoying My Rhino
 
Join Date: Oct 2007
Location: N Phx
Posts: 6,192
if u have full power 12-14 volts and spark & fuel to carb keep crankin

07 660 SE - White Carbon Fiber Body Kit - Dual SS Polished Muzzy Exhaust - Dynatek CDi - Innovate LC-1 WideBand A/F Gauge Kit - K&N Intake System - Crappy Machine Sheave - 14 Gram Roller Weights - Orange EPI Spring - XMF Bed Delete Kit - Dual Batteries - (4) 7'' hid's - GBC 8ply Dirt Commanders - I-Pod system - PRP Seats - Crow Harnesses - Gear One Steering Rack - Rugged Race Radio 600-2p -
[url]www.unleashedutv.com[/url]
[url]http://www.traillogicllc.com/[/url]
Benzito is offline  
post #7 of 11 (permalink) Old 09-17-2009, 05:39 PM Thread Starter
Paper Boy
 
Join Date: Sep 2009
Posts: 16
Battery is fine.The engine just won't turnover to actually start. Just keeps trying to start but won't idle or sound like it's trying to
stefan07rhino is offline  
post #8 of 11 (permalink) Old 09-17-2009, 05:41 PM Thread Starter
Paper Boy
 
Join Date: Sep 2009
Posts: 16
So it wont start but turns over excuse me
stefan07rhino is offline  
post #9 of 11 (permalink) Old 09-17-2009, 05:47 PM
Enjoying My Rhino
 
Join Date: Oct 2007
Location: N Phx
Posts: 6,192
check ur spark?

spray a lil fuel in carb as ur cranking see if it starts that way.

07 660 SE - White Carbon Fiber Body Kit - Dual SS Polished Muzzy Exhaust - Dynatek CDi - Innovate LC-1 WideBand A/F Gauge Kit - K&N Intake System - Crappy Machine Sheave - 14 Gram Roller Weights - Orange EPI Spring - XMF Bed Delete Kit - Dual Batteries - (4) 7'' hid's - GBC 8ply Dirt Commanders - I-Pod system - PRP Seats - Crow Harnesses - Gear One Steering Rack - Rugged Race Radio 600-2p -
[url]www.unleashedutv.com[/url]
[url]http://www.traillogicllc.com/[/url]
Benzito is offline  
post #10 of 11 (permalink) Old 09-17-2009, 05:56 PM
Experienced
 
660Rhino's Avatar
 
Join Date: Apr 2009
Location: GP, Alberta
Posts: 546
Change your plug, mine did the same thing. I was driving it, parked it in my garage, started it the next day to move it and it died, wouldn't start. Changed my plug and it was good to go, it was even sparking with a spark test, but just wouldn't fire.
660Rhino is offline  
post #11 of 11 (permalink) Old 09-17-2009, 06:07 PM
Wholigan
 
Kong's Avatar
 
Join Date: Aug 2007
Location: SW Colorado
Posts: 1,012
Quote:
Originally Posted by 660Rhino View Post
Change your plug, mine did the same thing. I was driving it, parked it in my garage, started it the next day to move it and it died, wouldn't start. Changed my plug and it was good to go, it was even sparking with a spark test, but just wouldn't fire.
X2

Do this first. I had it happen and my firend (dealer owner) told me it happens to them at the shop from moving the UTV's ATVs in and out often and it is plug foul.

Good luck.

2008 700 FI
Kong is offline  
Reply

  Lower Navigation
Go Back   Yamaha Rhino Forum - Rhino Forums.net > Technical > Tutorials

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Rhino Forum - Rhino Forums.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome