Yamaha Rhino Forum

660 rhino sputters at higher rpm, not bad fule

This is a discussion on 660 rhino sputters at higher rpm, not bad fule within the New Members forums, part of the Members category; I,m new to this and not a good speller, am pretty mechinacaly inclined, but can't figure out why my rhino sputters and pops at around ...


Go Back   Yamaha Rhino Forum - Rhino Forums.net > Members > New Members


New Members Please introduce yourself, and welcome to Rhino forums!

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 08-26-2011, 08:18 AM
Member
 
Join Date: Aug 2011
Posts: 7
View jeeper's Photo Gallery(0)
Wrench 660 rhino sputters at higher rpm, not bad fule

I,m new to this and not a good speller, am pretty mechinacaly inclined, but can't figure out why my rhino sputters and pops at around 30 mph, i serviced the clutch so its not the rev limiter i dont think. new filters clean gas, i havent torn into the carb tho, does any one have a simmiliar problem?
Reply With Quote
Sponsored Links
RhinoForums.net is the premier Yamaha Rhino UTV/ATV Forum on the internet. Registered Users do not see these ads. Please Register - It's Free!
  #2 (permalink)  
Old 08-26-2011, 05:03 PM
Member
 
My Rhino: 06 660
Join Date: Jul 2011
Location: ridgeland
Posts: 71
View crazyazsredneck's Photo Gallery(0)
sounds like carb or fuel pump. mine did something like that and the diaphragm in carb had a hole in it, the fuel pump had just been changed cause the p.o. was told thats what could cause it , pull carb and clean it first , its cheaper than replacing fuel pump
__________________
06 660
27 mud lights 14 in itp rims
snorkled for crek ridding
200 w wake board speakers
to drained out belt noise
lots more to come
Reply With Quote
  #3 (permalink)  
Old 08-29-2011, 05:14 AM
Member
 
Join Date: Aug 2011
Posts: 7
View jeeper's Photo Gallery(0)
Talking

Thanks, I bought a new fuel pump before we went to the mountions, and sure enough it quit us,and with my luck i didn't bring my socket set and was able to change it out with a small china cresent and a screw driver, but runs fine now, we put close to 60 miles on it and no problem's. now the brakes make a terible noise when you go to stop, they have always been noisy but guess i need to put new pads on it, been looking at the Razor 4 but was told to give them a couple years to get the bugs worked has anyone herd how they do, Honestly I'm getting a little fed up with my rino, to darn noisey inside, I have put so much money into it with all the acceories I'm sure i can't get out of it what i have into it. Altho it is a work hourse, we came out last elk hunting with a 5 point bull and a spike and 4 people. that was pretty impressive. yea all in one load. Thanks so much will be watching this page, Hey!! wheres the us flag???
Reply With Quote
  #4 (permalink)  
Old 08-29-2011, 02:20 PM
Member
 
My Rhino: 06 660
Join Date: Jul 2011
Location: ridgeland
Posts: 71
View crazyazsredneck's Photo Gallery(0)
the razors are badd azs in the mud holes but u aint hauling no meat out of the woods with one , may be a dove hahhahahhahahhaha
__________________
06 660
27 mud lights 14 in itp rims
snorkled for crek ridding
200 w wake board speakers
to drained out belt noise
lots more to come
Reply With Quote
  #5 (permalink)  
Old 08-30-2011, 05:22 AM
Member
 
Join Date: Aug 2011
Posts: 7
View jeeper's Photo Gallery(0)
Well that all worked out well Thanks, Now is there any Honda old 4 wheeler machanics out there"? my old 4 trx 350 has a mind of its own, starts when it wants to and wont when it don't want to, It is electrical I know for sure I'm thinking a relay. but was told it might be the condenser, bad the wires are in good shape no power to the coil when it won't start. when it will start there is power to the two wires at the coil. has me all confused, paid the question guy but no luck? Help please???
Reply With Quote
  #6 (permalink)  
Old 08-30-2011, 02:13 PM
Member
 
My Rhino: 06 660
Join Date: Jul 2011
Location: ridgeland
Posts: 71
View crazyazsredneck's Photo Gallery(0)
yep bout bet u the gas tank has rub some wires into.pull the seat and tank off and start looking , also ckeck ur ground wires,
__________________
06 660
27 mud lights 14 in itp rims
snorkled for crek ridding
200 w wake board speakers
to drained out belt noise
lots more to come
Reply With Quote
  #7 (permalink)  
Old 08-30-2011, 05:20 PM
Member
 
Join Date: Aug 2011
Posts: 7
View jeeper's Photo Gallery(0)
ya think? For some reason I don't think so, but I will check it again. I have taken all the plastic off and checked that a couple times. it is the darndest thing, I was convinced it was like a relay sticking or maybe the condenser, But the week end is coming and i am going to figure it out, Thank you, i'll post what i find, might help someone out down the road. Thats what this is all about I think,,
Reply With Quote
  #8 (permalink)  
Old 08-31-2011, 02:48 PM
Member
 
My Rhino: 06 660
Join Date: Jul 2011
Location: ridgeland
Posts: 71
View crazyazsredneck's Photo Gallery(0)
the neutral safety switch , will cause problems , do ur lights come??
__________________
06 660
27 mud lights 14 in itp rims
snorkled for crek ridding
200 w wake board speakers
to drained out belt noise
lots more to come
Reply With Quote
  #9 (permalink)  
Old 08-31-2011, 03:40 PM
Kracker's Avatar
Member
 
First Name: Travis
My Rhino: 2006 4 seater
Join Date: Dec 2007
Location: Buckeye, AZ
Posts: 464
View Kracker's Photo Gallery(0)
Check the ground on your reverse rev limiter switch underneath your airbox....
Reply With Quote
  #10 (permalink)  
Old 09-01-2011, 12:43 PM
Member
 
Join Date: Aug 2011
Posts: 7
View jeeper's Photo Gallery(0)
I know this is for the Yamaha rhino forum, but thanks, for your suggestions, Yea! the thing turns over and cranks and cranks, but just wont start, I'm going to check this weekend for possible broken wire, I swear the thing has a mind of its own. Like an old man, being a pain in the neck, like me. You don't have to touch a thing and it starts , shut it off and come back later and it won't. or it might, its just to random to think it might be a broken wire, there are days when it will start every time and days when it wont, but just leave it alone and it might. You would have to be here, it is a old one but still a good one, sometimes, still has hope. if I could just nail this problem down. thanks
Reply With Quote
  #11 (permalink)  
Old 09-01-2011, 03:12 PM
Member
 
My Rhino: 06 660
Join Date: Jul 2011
Location: ridgeland
Posts: 71
View crazyazsredneck's Photo Gallery(0)
try highlifter .com and sign up on there honda forum i bet some one there has had the same problem
__________________
06 660
27 mud lights 14 in itp rims
snorkled for crek ridding
200 w wake board speakers
to drained out belt noise
lots more to come
Reply With Quote
  #12 (permalink)  
Old 09-06-2011, 06:05 AM
Member
 
Join Date: Aug 2011
Posts: 7
View jeeper's Photo Gallery(0)
Thank you I will do that,
Reply With Quote
Reply

Lower Navigation
Go Back   Yamaha Rhino Forum - Rhino Forums.net > Members > New Members


Search tags for this page

2006 yamaha 660 rhino reverse lite

,
four wheeler high rpm runs bad
,

four wheeler sputtering

,
four wheeler sputters at high rpm
,

my four wheeler sputtering

,

my yamaha rhino 660 sputters at high speed

,
rhino 660 misfire at high rpm
,
rhino 660 pops at steady rpm
,

rhino 660 sputtering

,

rhino 660 sputters

,
rhino sputtering at higher speeds
,

rhino sputters at high rpm

,

rhino sputters at rev limiter

,
yamaha grizzly 660 sputters when reved
,

yamaha rhino sputters

Click on a term to search our sites for related topics.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 06:39 AM.


Copyright 2008 BrianSquared LLC