Yamaha Rhino Forum

Neutral switch?

This is a discussion on Neutral switch? within the Lighting, Stereo, and Electrical forums, part of the Technical category; Ive got an 07 660 SE Rhino,, and am having trouble with starting.. it goes into neutral fine, but its really hard to get the ...


Go Back   Yamaha Rhino Forum - Rhino Forums.net > Technical > Lighting, Stereo, and Electrical

Lighting, Stereo, and Electrical For discussion of lighting, stereo, and other electrical components

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 02-25-2010, 07:59 PM
Member
 
First Name: Shawn
My Rhino: 07 Special Edition
Join Date: Aug 2009
Location: Missouri
Posts: 38
View angus's Photo Gallery(0)
Neutral switch?

Ive got an 07 660 SE Rhino,, and am having trouble with starting.. it goes into neutral fine, but its really hard to get the neutral light to come on, and if the light isnt on, it wont start..... Same trouble with the brake,, the switch that activates the brake lights is the same that allows starting in gear.. and it isnt working either. Is there somewhere to get these items, or is there a fix to cure my trouble.. its getting really aggravating.. Thanks
Reply With Quote
Sponsored Links
RhinoForums.net is the premier Yamaha Rhino UTV/ATV Forum on the internet. Registered Users do not see these ads. Please Register - It's Free!
  #2 (permalink)  
Old 02-25-2010, 10:53 PM
fasttrax's Avatar
Member
 
My Rhino: 2006 686SE
Join Date: Nov 2008
Location: UTAH!
Posts: 314
View fasttrax's Photo Gallery(4)
I would check all the wires coming out from under the stock air cleaner to start. You might have a loose one or maybe melted. I think the gear sensor is the one on the backside of the shift linkage, could be wrong.
__________________
06' 660SE custom 4 seat cage w/ CP686 11:1, web cam, muzzy exhaust, dynatek CDI, Venom winch, MTX audio
Reply With Quote
  #3 (permalink)  
Old 02-26-2010, 07:01 AM
Member
 
First Name: Shawn
My Rhino: 07 Special Edition
Join Date: Aug 2009
Location: Missouri
Posts: 38
View angus's Photo Gallery(0)
Ok thanks,, Ill check it. It almost seems like a position sensor or something, as it seems to have a tiny area that it will come on, but you have to very carefully move the shifter around a little till it comes on, but it seems in colder weather it is much harder to find the spot.. if that makes sense.. but its getting aggravating,, if Im out riding and shut it off, it may take me 15 minutes to get it started again! Ill chech it out,, again,, thanks.
Reply With Quote
  #4 (permalink)  
Old 03-01-2010, 06:32 PM
Member
 
First Name: Shawn
My Rhino: 07 Special Edition
Join Date: Aug 2009
Location: Missouri
Posts: 38
View angus's Photo Gallery(0)
Well,,, Im sure not getting much help on this here!

Maybe if I word it different....

Does anyone know where the sensor or switch is at that turns on the nuetral light when it is shifted to neutral?

Also, where can I get a new switch that activates the brake lights on a Rhino.. I keep asking these questions and calling dealerships and everyone acts like Im an idiot and no one knows what Im talking about!..

Can anyone help me please?

That said... Yes I have checked the wiring, the brake light switch is bad for some reason, but I dont seem to be able to find one to buy anywhere, I can jump across the terminals on the brake light switch and it will start... I can also adjust my shift linkage and the light will come on and it will start,, but the first time I shift it out of neutral and back into neutral, no light,, so evidently that switch is bad also, but I am unable to find it anywhere.... Thanks for anything you guys can give me here.
Reply With Quote
  #5 (permalink)  
Old 03-01-2010, 07:10 PM
Rhino4me's Avatar
Member
 
First Name: Rodney
My Rhino: 2006 Rhino 660
Join Date: Jan 2010
Location: Near Charleston, South Carolina
Posts: 246
View Rhino4me's Photo Gallery(0)
The neutral switch, if I am not mistaken, is located on the back side of the shifter. I had trouble with a switch on mine, but I don't remember if it was the reverse switch or the neutral. The switch I had trouble with was a micro switch and was mounted to a bracket with one screw (which is what I had to replace) and the other end of the switch has a tab. I have not had any trouble with my brake lights, but you may be able to clean the switch with a good contact cleaner and check the switch with an ohm meter afterward. The switch may just be contaminated with dirt/mud. To access the switch behind the shifter, remove the e-brake rubber boot, remove the engine cover, and check the switch at the rear of the shifter. I found mine just hanging by the wire. Good luck!

Oh....one other thing. My Rhino will crank up whether it is FWD, N, or REV. It doesn't have to be in neutral to crank, or atleast mine don't.
__________________
2006 Rhino 660 Camo Edition, ITP rims, STI Mud Trax tires 26"x9"x12" Front, 26"X11"x12" Rear, Alba Racing S/S Exhaust, Dynojet, Twin air Filter, Moose Ignition kit, WARN 3000lb winch, J-Strong 1/2 doors, Kolpin Neoprene seat covers, BRP Fuel Gauge, UTV inc. Dash plate....
Reply With Quote
  #6 (permalink)  
Old 03-02-2010, 06:04 PM
Member
 
First Name: Shawn
My Rhino: 07 Special Edition
Join Date: Aug 2009
Location: Missouri
Posts: 38
View angus's Photo Gallery(0)
Its not on the shifter,, Ive already been in there and looked for it,, nothing around teh shifter except the parking brake light switch. Mine will only start in gear with the brake pushed,, and if the brake lights dont light up, then it dont start then either..lol I found a place to order what I need today from a dealership,, (the brake switch). They couldnt even tell me at the dealership where the neutral switch is located! But they can give me a price on one though!
Reply With Quote
  #7 (permalink)  
Old 03-03-2010, 09:12 AM
07fj's Avatar
Rainman
Premium Member
 
First Name: rog
My Rhino: 07 660 Sport
Join Date: Oct 2007
Location: Ramona, Ca
Posts: 6,806
View 07fj's Photo Gallery(1)
under air box, just forward of the oil filter housing, gear position switch. not the single wire one, that is for rev.
__________________


LOORRS Rookie of the Year
Unlimited UTV 2009

Benchmark 686, (67.6 RWHP )
HRT Motorsports cage, LSR XTR 6.5
Rugged RRP600
www.unleashedutv.com
Reply With Quote
  #8 (permalink)  
Old 03-03-2010, 06:21 PM
Member
 
First Name: Shawn
My Rhino: 07 Special Edition
Join Date: Aug 2009
Location: Missouri
Posts: 38
View angus's Photo Gallery(0)
Thank you,, Ill check it out
Reply With Quote
  #9 (permalink)  
Old 05-04-2010, 03:30 PM
Member
 
Join Date: Sep 2009
Posts: 11
View tjt340's Photo Gallery(0)
their is two bolts on it. be careful when you pull it out that you dont break the housing. you can lightly sand the contacts then put some dielectric grease on them. i bought a new one and still have to fight with it.
Reply With Quote
  #10 (permalink)  
Old 02-10-2011, 05:24 PM
Member
 
Join Date: Nov 2010
Posts: 2
View Doral man's Photo Gallery(0)
I am having the same problem. Did you find the fix??
Reply With Quote
  #11 (permalink)  
Old 02-10-2011, 07:58 PM
spyder152's Avatar
Member
 
First Name: Sal
My Rhino: 2006 660
Join Date: Mar 2010
Location: Nuevo, Ca
Posts: 136
View spyder152's Photo Gallery(0)
mine does the same thing, ignore it and push the brake and it will start.
Reply With Quote
  #12 (permalink)  
Old 10-16-2011, 01:12 PM
Member
 
Join Date: Oct 2011
Posts: 175
View rampage11's Photo Gallery(0)
mine wont start in gear..t is that?
Reply With Quote
  #13 (permalink)  
Old 10-16-2011, 02:29 PM
RuttingRhino's Avatar
Senior Member
 
First Name: Craig
My Rhino: Red 07
Join Date: Jan 2011
Location: Tempe, AZ
Posts: 3,239
View RuttingRhino's Photo Gallery(0)
You do know that you have depress the brake pedal when in gear to for the starter relay to engage right...

Is it a stock cdi...???
__________________
We are closed...2013
Reply With Quote
  #14 (permalink)  
Old 10-16-2011, 06:01 PM
Member
 
Join Date: Oct 2011
Posts: 175
View rampage11's Photo Gallery(0)
lol..yes.. maybe my sensor needs adjusted.. dynatek cdi
Reply With Quote
  #15 (permalink)  
Old 10-16-2011, 06:03 PM
RuttingRhino's Avatar
Senior Member
 
First Name: Craig
My Rhino: Red 07
Join Date: Jan 2011
Location: Tempe, AZ
Posts: 3,239
View RuttingRhino's Photo Gallery(0)
Try the stock cdi just to make sure...probably not it...simple to do...
__________________
We are closed...2013
Reply With Quote
Reply

Lower Navigation
Go Back   Yamaha Rhino Forum - Rhino Forums.net > Technical > Lighting, Stereo, and Electrical


Search tags for this page
2001 yamaha rhino neutral safety switch
,
2005 rhino 660 side by side - neutral safety switch
,
2006 rhino neutral switch video
,
660 rhino noutrol safety switch
,
660 rhino safty park switch
,
neutral safety switch yamaha rhino
,
neutral switch on 2007 yamaha rhino
,
nuetral safety switch 660 rhino
,
removing neutral switch on rhino
,
rhino 660 neutral switch
,
rhino neutral light
,
were is the neutral saftey switch on 2006 660 yamha rhino
,

yamaha rhino neutral safety switch

,

yamaha rhino neutral safety switch location

,
yamaha rino 660 netural safty switch.
Click on a term to search our sites for related topics.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 05:25 AM.


RhinoForums.net is not associated with Yamaha in any way. We are an enthusiast site dedicated to the Yamaha Rhino. Our goal is to offer a place for Yamaha Rhino owners to discuss rides, events, mods, maintenance, purchasing, etc and offer help and assistance.