Yamaha Rhino Forum

Rhino went dead

This is a discussion on Rhino went dead within the How-To forums, part of the General Rhino category; Today I simpl added some coolant to my 05 rhino 660 backed it out of my barn. It conked out and wouldn't even turnover from ...


Go Back   Yamaha Rhino Forum - Rhino Forums.net > General Rhino > How-To

How-To For Modifications, Bolt-Ons, Maintenance and Troubleshooting How-To's - Pictures make it better!

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 09-17-2009, 07:46 AM
Member
 
Join Date: Sep 2009
Posts: 16
View stefan07rhino's Photo Gallery(0)
Rhino went dead

Today I simpl added some coolant to my 05 rhino 660 backed it out of my barn. It conked out and wouldn't even turnover from there on. What do I do? I have a trail ride saturday
Reply With Quote
Sponsored Links
RhinoForums.net is the premier Yamaha Rhino UTV/ATV Forum on the internet. Registered Users do not see these ads. Please Register - It's Free!
  #2 (permalink)  
Old 09-17-2009, 09:05 AM
dhc-6's Avatar
Member
 
First Name: Steve
My Rhino: 2008 700 EFI
Join Date: Dec 2007
Location: Eloy,AZ
Posts: 810
View dhc-6's Photo Gallery(0)
When my battery went dead on my 700 I could jump it and get it running but as soon as I tried to put it into gear it would die and would not turn over....The battery was fine the night befor but dead the next morning...**** happens!!!!
Reply With Quote
  #3 (permalink)  
Old 09-17-2009, 09:06 AM
western196611's Avatar
Short Member
 
First Name: Bob
My Rhino: 2008 800 rzr
Join Date: Mar 2009
Location: Central Kansas
Posts: 968
View western196611's Photo Gallery(0)
I would start out by checking the battery. Can you hear the silinod (Spelling)click?
__________________
2008 Polaris RZR 800, long travel kit, Rhino brand axles, Offset A-arms, XP shocks, New front differential with billet cage, PA doors, Super ATV 4500 pound winch.
Reply With Quote
  #4 (permalink)  
Old 09-17-2009, 10:54 AM
07fj's Avatar
Rainman
Premium Member
 
First Name: rog
My Rhino: 07 660 Sport
Join Date: Oct 2007
Location: Ramona, Ca
Posts: 6,806
View 07fj's Photo Gallery(1)
Quote: Originally Posted by stefan07rhino View Post
Today I simpl added some coolant to my 05 rhino 660 backed it out of my barn. It conked out and wouldn't even turnover from there on. What do I do? I have a trail ride saturday
would not turn over or would not start, when rhino's set for a while the gas in the bowl can dry out, takes a while to prime the pump and get gas to the bowl again.

if does not turn over then jump start it and see what happens, I suggest a good charge before you go and/or bring jump cables just in case the batt is going bad.


Rog
__________________


LOORRS Rookie of the Year
Unlimited UTV 2009

Benchmark 686, (67.6 RWHP )
HRT Motorsports cage, LSR XTR 6.5
Rugged RRP600
www.unleashedutv.com
Reply With Quote
  #5 (permalink)  
Old 09-17-2009, 04:29 PM
660Rhino's Avatar
Member
 
First Name: Jason
My Rhino: 2013 polaris 850XP
Join Date: Apr 2009
Location: GP, Alberta
Posts: 546
View 660Rhino's Photo Gallery(0)
If there is no power at all, check the ignition fuse under the battery cover, clean battery posts, general wire check.

I don't recommend charging a battery while the ground is still connected because it can and has in the passed fried the digi dash. And as 07fj mentioned a good charge to see if it will start before any boosting.
Reply With Quote
  #6 (permalink)  
Old 09-17-2009, 04:42 PM
Banned
 
First Name: YANK
My Rhino: 07 660 SE
Join Date: Oct 2007
Location: N Phx
Posts: 6,192
View Benzito's Photo Gallery(8)
if u have full power 12-14 volts and spark & fuel to carb keep crankin
Reply With Quote
  #7 (permalink)  
Old 09-17-2009, 05:39 PM
Member
 
Join Date: Sep 2009
Posts: 16
View stefan07rhino's Photo Gallery(0)
Battery is fine.The engine just won't turnover to actually start. Just keeps trying to start but won't idle or sound like it's trying to
Reply With Quote
  #8 (permalink)  
Old 09-17-2009, 05:41 PM
Member
 
Join Date: Sep 2009
Posts: 16
View stefan07rhino's Photo Gallery(0)
So it wont start but turns over excuse me
Reply With Quote
  #9 (permalink)  
Old 09-17-2009, 05:47 PM
Banned
 
First Name: YANK
My Rhino: 07 660 SE
Join Date: Oct 2007
Location: N Phx
Posts: 6,192
View Benzito's Photo Gallery(8)
check ur spark?

spray a lil fuel in carb as ur cranking see if it starts that way.
Reply With Quote
  #10 (permalink)  
Old 09-17-2009, 05:56 PM
660Rhino's Avatar
Member
 
First Name: Jason
My Rhino: 2013 polaris 850XP
Join Date: Apr 2009
Location: GP, Alberta
Posts: 546
View 660Rhino's Photo Gallery(0)
Change your plug, mine did the same thing. I was driving it, parked it in my garage, started it the next day to move it and it died, wouldn't start. Changed my plug and it was good to go, it was even sparking with a spark test, but just wouldn't fire.
Reply With Quote
  #11 (permalink)  
Old 09-17-2009, 06:07 PM
Kong's Avatar
Site Supporter
Premium Member
 
My Rhino: 2008
Join Date: Aug 2007
Location: SW Colorado
Posts: 1,012
View Kong's Photo Gallery(0)
Quote: Originally Posted by 660Rhino View Post
Change your plug, mine did the same thing. I was driving it, parked it in my garage, started it the next day to move it and it died, wouldn't start. Changed my plug and it was good to go, it was even sparking with a spark test, but just wouldn't fire.
X2

Do this first. I had it happen and my firend (dealer owner) told me it happens to them at the shop from moving the UTV's ATVs in and out often and it is plug foul.

Good luck.
__________________
2008 700 FI
Reply With Quote
Reply

Lower Navigation
Go Back   Yamaha Rhino Forum - Rhino Forums.net > General Rhino > How-To


Search tags for this page
06 rhino starts the dies and fouls plug
,
2008 700 efi yamaha rhino spins over but wont crank
,

2009 yamaha rhino 700 efi battery keeps going dead

,
rhino 660 goes dead when i put it in gear
,

rhino 660 not turn over

,
rhino 700 efi wont idle
,
rhino battery going dead
,

yamaha rhino battery keeps going dead

,
yamaha rhino dead
,
yamaha rhino dead battery wont start even when plugged to charger
,
yamaha rhino engine wont turn over unless spark plug is out
,
yamaha rhino keeps going dead
,
yamaha rhino want start battery dead
,

yamaha rhino wont turn over

,
yamaha rhino wont turn over with plug in it
Click on a term to search our sites for related topics.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 03:17 PM.


RhinoForums.net is not associated with Yamaha in any way. We are an enthusiast site dedicated to the Yamaha Rhino. Our goal is to offer a place for Yamaha Rhino owners to discuss rides, events, mods, maintenance, purchasing, etc and offer help and assistance.