Yamaha Rhino Forum

Neutral light indicator not always working..

This is a discussion on Neutral light indicator not always working.. within the How-To forums, part of the General Rhino category; Do any of you have this happen when you shift into neutral? Mine does it around 1/2 of the times I do it...I read where ...


Go Back   Yamaha Rhino Forum - Rhino Forums.net > General Rhino > How-To

How-To For Modifications, Bolt-Ons, Maintenance and Troubleshooting How-To's - Pictures make it better!

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 04-06-2009, 06:57 PM
PatrickB's Avatar
Member
 
Join Date: Mar 2009
Posts: 77
View PatrickB's Photo Gallery(0)
Neutral light indicator not always working..

Do any of you have this happen when you shift into neutral? Mine does it around 1/2 of the times I do it...I read where you can clean the contacts for the shifter and it should fix this? Is this part behind that flat cover with 3 hex bolts under the gearshift rod? thanks
__________________
2007 Ducks Unlimited Rhino 660 w/Tri-Fire CDI, OEM fender flares, roof, headlight and taillight guards, center console, Moose rear bumper, front mudflaps, 26" Bighorn 2.0's, bedrails, tailgate strip, floormats, Bear Claw 3500 winch, 2" rear spacers, Trail Logic gusset set, and Yamaha half windshield.
Reply With Quote
Sponsored Links
RhinoForums.net is the premier Yamaha Rhino UTV/ATV Forum on the internet. Registered Users do not see these ads. Please Register - It's Free!
  #2 (permalink)  
Old 04-07-2009, 04:05 AM
jixxer's Avatar
BOOSTED MEMBER
 
My Rhino: 2007 SE 660
Join Date: Dec 2008
Location: Elizabethtown, Ky.
Posts: 45
View jixxer's Photo Gallery(0)
subscribing!
__________________


2007 SE 660 Rhino

1990 Titanium Frost Coupe Quicktimeturbo System 501RWHP
Reply With Quote
  #3 (permalink)  
Old 04-07-2009, 04:49 AM
Official Site Vendor
Premium Member
 
Join Date: Jan 2009
Posts: 2,212
View Hunterworks's Photo Gallery(0)
It is the contacts on the switch which is bolted to the top of the transmission under and to left of shift.

It is round with two screw mounting locations on each side. Remove it and clean the contacts on it and the opposing surface.

Todd
__________________
Todd
www.hunterworks.com
todd@hunterworks.com
601-771-0070
Reply With Quote
  #4 (permalink)  
Old 04-07-2009, 04:58 AM
indover34's Avatar
Member
 
First Name: Tim
My Rhino: 08 & 09 Midnights
Join Date: Jan 2008
Location: Dover, Ohio
Posts: 404
View indover34's Photo Gallery(35) Send a message via Yahoo to indover34
That is normal, I haven't seen a rhino of any year that didn't do that. Just pass "N" and come back from the other direction.
__________________
2008 700fi Midnight Black
2009 700fi Midnight Red
Hunterworks sheave
Hunterworks 72" plow
Warn RT3000
Huge brass nuts
http://www.myspace.com/timpedersen
http://www.youtube.com/user/timapedersen
Reply With Quote
  #5 (permalink)  
Old 04-07-2009, 06:00 AM
PatrickB's Avatar
Member
 
Join Date: Mar 2009
Posts: 77
View PatrickB's Photo Gallery(0)
Hey thanks guys, I will try cleaning those contacts and see if it helps.
__________________
2007 Ducks Unlimited Rhino 660 w/Tri-Fire CDI, OEM fender flares, roof, headlight and taillight guards, center console, Moose rear bumper, front mudflaps, 26" Bighorn 2.0's, bedrails, tailgate strip, floormats, Bear Claw 3500 winch, 2" rear spacers, Trail Logic gusset set, and Yamaha half windshield.
Reply With Quote
  #6 (permalink)  
Old 04-17-2011, 10:13 PM
Member
 
Join Date: Apr 2011
Posts: 1
View Gio650's Photo Gallery(0)
Do u have a pic
Reply With Quote
  #7 (permalink)  
Old 09-20-2011, 07:30 PM
Bill
 
First Name: William
My Rhino: 2011 Rhino 700
Join Date: Sep 2011
Location: Idaho
Posts: 250
View wildbill23c's Photo Gallery(0)
Mine does it sometimes too, and mine has done it since brand new. All I do is shift back into gear then back into neutral and it lights up.
Reply With Quote
  #8 (permalink)  
Old 11-30-2011, 08:53 PM
Member
 
Join Date: Sep 2007
Posts: 190
View zeddy's Photo Gallery(0)
Is it the same contact for H? Mine doesn't indicate High after it has warmed up
Reply With Quote
Reply

Lower Navigation
Go Back   Yamaha Rhino Forum - Rhino Forums.net > General Rhino > How-To


Search tags for this page
2004 yahama rhino 660 netural lite works sometimes
,
2007 yamaha rhino light indicator
,
2007 yamaha rhino neutral light
,
bypass rhino neutral
,
changing a yamaha rhino neutral switch
,
grizzly 660 neutral light
,
rhino 660 neutral switch
,
rhino nuetral switch pics
,
yamaha 650 rhino neutral light
,
yamaha grizzley neautral light
,
yamaha grizzly neutral light not working
,
yamaha rhino netural light doesnt go on
,

yamaha rhino neutral light not working

,
yamaha rhino neutral switch
,
yamaha rhino not starting
Click on a term to search our sites for related topics.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 08:04 PM.


RhinoForums.net is not associated with Yamaha in any way. We are an enthusiast site dedicated to the Yamaha Rhino. Our goal is to offer a place for Yamaha Rhino owners to discuss rides, events, mods, maintenance, purchasing, etc and offer help and assistance.