Red reverse light flashing when going in foward gear - Yamaha Rhino Forum - Rhino Forums.net
General Rhino Discussion For General Rhino Discussion

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 07-25-2010, 06:12 PM Thread Starter
Spectator
 
EAO HarleyMan's Avatar
 
Join Date: Jul 2010
Location: Polk City Fl
Posts: 4
Red reverse light flashing when going in foward gear

Hi all I am new here this is my first post. I have a 2006 Rhino 660 and the red reverse light on the dash panel lights solid red when in reverse gear like it it supposed to. When I put it in foward gear and start moving foward I will go about 200 feet and the red reverse starts blinking on and off as I drive foward. Has anyone else had this problem and know what is causing it or how to fix it.

Thanks

Jerry
EAO HarleyMan is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 07-25-2010, 08:08 PM
Ripsaw
 
Joe Llamahead's Avatar
 
Join Date: Jul 2007
Location: Southern Oregon Coast
Posts: 1,368
the switch located on top of the motor assy just under the aircleaner box has a (green wire with a white tracer) is engenieered to be normally closed grounding the circuit. when the tranny goes into reverse the grounf lifts. and the light goes on.
The problem with this araingment is if you loose conection anywhere between the relay and the switch, it trips the light.

The easy fix is to simply ground the wire. but then you got no indicator. if thats not to your liking ,you can can follow the wire back up stream and remove the conector solder it and shrink wrap it then clean the conections at the switch real good and use some dielectric greese. see if that fixes it.
if not you may need a switch. lot of switches get replaced first. but it's best to do the clean up before you go changing parts.
Joe Llamahead is offline  
post #3 of 4 (permalink) Old 07-26-2010, 04:41 AM Thread Starter
Spectator
 
EAO HarleyMan's Avatar
 
Join Date: Jul 2010
Location: Polk City Fl
Posts: 4
Thanks for the reply Joe I'll give that a try before I replace the switch.

Again thanks

Jerry
EAO HarleyMan is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 03-07-2011, 05:38 AM
Rocket
 
Wheels's Avatar
 
Join Date: Nov 2007
Location: Birmingham, Alabama
Posts: 851
good info Joe... thanks for that. i'm having the same issue, but with my 'H' flashing when in neutral.

09 Teryx
Wheels is offline  
Reply

  Lower Navigation
Go Back   Yamaha Rhino Forum - Rhino Forums.net > General Rhino > General Rhino Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Rhino Forum - Rhino Forums.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome