Yamaha Rhino Forum

knock sound in clutch

This is a discussion on knock sound in clutch within the Engine forums, part of the Technical category; when i put my choke on or hold my foot just on the gas to bring up the rpms to around 200ish i get a ...


Go Back   Yamaha Rhino Forum - Rhino Forums.net > Technical > Engine

Engine For discussion of engine performance, and maintenance

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 12-09-2010, 05:52 AM
rhinoless's Avatar
jackstand pimpin
 
First Name: lee
My Rhino: 05 660
Join Date: Feb 2010
Location: iowa
Posts: 663
View rhinoless's Photo Gallery(0) Send a message via AIM to rhinoless
knock sound in clutch

when i put my choke on or hold my foot just on the gas to bring up the rpms to around 200ish i get a knock sound in my clutchs but no weigths are losse. the sound will go away before 3000 rpms its only it its with in 500 rpms or so and when the sound is gone is there a knocking sound when the clutch 1st starts to work?
__________________
benchmark 686 kit/benchmark cam pins
webb cam,kibblewhite valve spring kit
k&n air filter/hsr 45
utv crap clutch part just that crap..gone
dyantek cdi /high pump/link kit
eagle 72" snow plow/rt40/ odssey battery/12" brembo brake kit
muzzy's exhaust
zilla 27" tires 55mph on crap clutch
Reply With Quote
Sponsored Links
RhinoForums.net is the premier Yamaha Rhino UTV/ATV Forum on the internet. Registered Users do not see these ads. Please Register - It's Free!
  #2 (permalink)  
Old 12-09-2010, 07:26 PM
rhinoless's Avatar
jackstand pimpin
 
First Name: lee
My Rhino: 05 660
Join Date: Feb 2010
Location: iowa
Posts: 663
View rhinoless's Photo Gallery(0) Send a message via AIM to rhinoless
noone else has ever had a knock sound?
__________________
benchmark 686 kit/benchmark cam pins
webb cam,kibblewhite valve spring kit
k&n air filter/hsr 45
utv crap clutch part just that crap..gone
dyantek cdi /high pump/link kit
eagle 72" snow plow/rt40/ odssey battery/12" brembo brake kit
muzzy's exhaust
zilla 27" tires 55mph on crap clutch
Reply With Quote
  #3 (permalink)  
Old 01-11-2011, 10:36 AM
rhinoless's Avatar
jackstand pimpin
 
First Name: lee
My Rhino: 05 660
Join Date: Feb 2010
Location: iowa
Posts: 663
View rhinoless's Photo Gallery(0) Send a message via AIM to rhinoless
any ideas at all anyone else had a knock in the clutchs or tranny after a rebuild or before im kinda at a dead end
__________________
benchmark 686 kit/benchmark cam pins
webb cam,kibblewhite valve spring kit
k&n air filter/hsr 45
utv crap clutch part just that crap..gone
dyantek cdi /high pump/link kit
eagle 72" snow plow/rt40/ odssey battery/12" brembo brake kit
muzzy's exhaust
zilla 27" tires 55mph on crap clutch
Reply With Quote
  #4 (permalink)  
Old 01-11-2011, 11:39 AM
RuttingRhino's Avatar
Senior Member
 
First Name: Craig
My Rhino: Red 07
Join Date: Jan 2011
Location: Tempe, AZ
Posts: 3,239
View RuttingRhino's Photo Gallery(0)
I would take the cover off and get a better look at/listen to of the problem.

Maybe you did that....

Gonna be real hard for anyone on the boards to identify that sound but I would think if anyone could help you Benchmark could...
__________________
We are closed...2013
Reply With Quote
  #5 (permalink)  
Old 01-11-2011, 12:30 PM
benzo's Avatar
Can-Am-camshaw icecreamtruck
 
My Rhino: jeep
Join Date: Mar 2010
Location: phx
Posts: 5,358
View benzo's Photo Gallery(0)
YES they all make that clunking goofy noise at low rpms , ur fine , make sure the 22mm bolt is tight and ur good
Reply With Quote
  #6 (permalink)  
Old 01-11-2011, 12:58 PM
rhinoless's Avatar
jackstand pimpin
 
First Name: lee
My Rhino: 05 660
Join Date: Feb 2010
Location: iowa
Posts: 663
View rhinoless's Photo Gallery(0) Send a message via AIM to rhinoless
why do they make that clunking sound right off idle? i mean if they all do then im ok with it but still seems like a dealer would have wanted that fixed but maybe im just picky lol

Quote: Originally Posted by benzo View Post
YES they all make that clunking goofy noise at low rpms , ur fine , make sure the 22mm bolt is tight and ur good
__________________
benchmark 686 kit/benchmark cam pins
webb cam,kibblewhite valve spring kit
k&n air filter/hsr 45
utv crap clutch part just that crap..gone
dyantek cdi /high pump/link kit
eagle 72" snow plow/rt40/ odssey battery/12" brembo brake kit
muzzy's exhaust
zilla 27" tires 55mph on crap clutch
Reply With Quote
  #7 (permalink)  
Old 01-11-2011, 01:26 PM
RuttingRhino's Avatar
Senior Member
 
First Name: Craig
My Rhino: Red 07
Join Date: Jan 2011
Location: Tempe, AZ
Posts: 3,239
View RuttingRhino's Photo Gallery(0)
I think benzo is talking about the grinding/groaning noise that most if not all will make when you hit the brakes abruptly at low speeds.

That would be the cvt dis-engaging. When the vehicle slows down to a stop...the sheave lets go of the belt so it doesn't move forward while in gear at idle.

If you stop abruptly it lets go abruptly...sound can be very unsettling.

What you are descriping SOUNDS more like something broke, missing, or incorrectly installed.

I have never had what you describe happen to me and that with a zillion or two holeshots...many on pavement...lots of cvt trial and error etc.

I suggest you make sure it isn't a problem.

I can tell peeps have had cases break from cvt shiz breaking bad on them....not often...but still...
__________________
We are closed...2013
Reply With Quote
  #8 (permalink)  
Old 01-11-2011, 01:36 PM
onebuilder's Avatar
Senior Member
 
First Name: Steve
My Rhino: '06-686
Join Date: Jun 2007
Location: Skull Valley, AZ
Posts: 2,486
View onebuilder's Photo Gallery(0)
Lee, Check the cam plate for wear, especially the splined area and the area where the sliders go on it. Mine had lots of wear in the slider area. I relpaced everything, cam plate sliders and the little metal clips.
__________________
Dirt flies when you're having fun!
Reply With Quote
  #9 (permalink)  
Old 01-11-2011, 01:37 PM
rhinoless's Avatar
jackstand pimpin
 
First Name: lee
My Rhino: 05 660
Join Date: Feb 2010
Location: iowa
Posts: 663
View rhinoless's Photo Gallery(0) Send a message via AIM to rhinoless
its in the big clutch with the spring on it or the tranny
__________________
benchmark 686 kit/benchmark cam pins
webb cam,kibblewhite valve spring kit
k&n air filter/hsr 45
utv crap clutch part just that crap..gone
dyantek cdi /high pump/link kit
eagle 72" snow plow/rt40/ odssey battery/12" brembo brake kit
muzzy's exhaust
zilla 27" tires 55mph on crap clutch
Reply With Quote
  #10 (permalink)  
Old 01-12-2011, 11:56 AM
07fj's Avatar
Rainman
Premium Member
 
First Name: rog
My Rhino: 07 660 Sport
Join Date: Oct 2007
Location: Ramona, Ca
Posts: 6,806
View 07fj's Photo Gallery(1)
sound like a roller out of place maybe.
__________________


LOORRS Rookie of the Year
Unlimited UTV 2009

Benchmark 686, (67.6 RWHP )
HRT Motorsports cage, LSR XTR 6.5
Rugged RRP600
www.unleashedutv.com
Reply With Quote
  #11 (permalink)  
Old 01-12-2011, 11:58 AM
rhinoless's Avatar
jackstand pimpin
 
First Name: lee
My Rhino: 05 660
Join Date: Feb 2010
Location: iowa
Posts: 663
View rhinoless's Photo Gallery(0) Send a message via AIM to rhinoless
Quote: Originally Posted by 07fj View Post
sound like a roller out of place maybe.
checked that a couple times its in the other clutch the big one with the big or the tranny
__________________
benchmark 686 kit/benchmark cam pins
webb cam,kibblewhite valve spring kit
k&n air filter/hsr 45
utv crap clutch part just that crap..gone
dyantek cdi /high pump/link kit
eagle 72" snow plow/rt40/ odssey battery/12" brembo brake kit
muzzy's exhaust
zilla 27" tires 55mph on crap clutch
Reply With Quote
  #12 (permalink)  
Old 01-12-2011, 12:04 PM
07fj's Avatar
Rainman
Premium Member
 
First Name: rog
My Rhino: 07 660 Sport
Join Date: Oct 2007
Location: Ramona, Ca
Posts: 6,806
View 07fj's Photo Gallery(1)
Quote: Originally Posted by rhinoless View Post
Quote: Originally Posted by 07fj View Post
sound like a roller out of place maybe.
checked that a couple times its in the other clutch the big one with the big or the tranny
the secondary?

that one has pins inside it to rotate the halves. may need grease
__________________


LOORRS Rookie of the Year
Unlimited UTV 2009

Benchmark 686, (67.6 RWHP )
HRT Motorsports cage, LSR XTR 6.5
Rugged RRP600
www.unleashedutv.com
Reply With Quote
  #13 (permalink)  
Old 01-12-2011, 12:08 PM
rhinoless's Avatar
jackstand pimpin
 
First Name: lee
My Rhino: 05 660
Join Date: Feb 2010
Location: iowa
Posts: 663
View rhinoless's Photo Gallery(0) Send a message via AIM to rhinoless
yea the secondary. good point ill pull it off and clean and grease.it was really hard to move wihout the spring but i though thats how the are so i just put it on after changing springs

Quote: Originally Posted by 07fj View Post
Quote: Originally Posted by rhinoless View Post
Quote: Originally Posted by 07fj View Post
sound like a roller out of place maybe.
checked that a couple times its in the other clutch the big one with the big or the tranny
the secondary?

that one has pins inside it to rotate the halves. may need grease
__________________
benchmark 686 kit/benchmark cam pins
webb cam,kibblewhite valve spring kit
k&n air filter/hsr 45
utv crap clutch part just that crap..gone
dyantek cdi /high pump/link kit
eagle 72" snow plow/rt40/ odssey battery/12" brembo brake kit
muzzy's exhaust
zilla 27" tires 55mph on crap clutch
Reply With Quote
  #14 (permalink)  
Old 01-14-2011, 12:41 PM
rhinoless's Avatar
jackstand pimpin
 
First Name: lee
My Rhino: 05 660
Join Date: Feb 2010
Location: iowa
Posts: 663
View rhinoless's Photo Gallery(0) Send a message via AIM to rhinoless
found the knock today when trying to find out why my **** is slow. the clutch cage spider looking thing was missing a bolt and the other 3 was losse so i fixed that no more knock. also i found out my belt get to the top of my primary clutch before it gose all the way down on the 2ct clutch so i think i need to go back to the stock roll weight and see if that dont give me more speed
__________________
benchmark 686 kit/benchmark cam pins
webb cam,kibblewhite valve spring kit
k&n air filter/hsr 45
utv crap clutch part just that crap..gone
dyantek cdi /high pump/link kit
eagle 72" snow plow/rt40/ odssey battery/12" brembo brake kit
muzzy's exhaust
zilla 27" tires 55mph on crap clutch
Reply With Quote
Reply

Lower Navigation
Go Back   Yamaha Rhino Forum - Rhino Forums.net > Technical > Engine


Search tags for this page
bad knocking noise from my clutch area on my 660 rhino
,
grizzly 660 knocking clutch
,
grizzly 660 knocking noise from belt area
,
grizzly 660 makes a knocking noise at low idle?
,
grizzly clutch knock
,

grizzly clutch knocking

,
how tight to bolt on 660grizzly wet clutch
,

ninja 500 rubbing sound from clutch area when idle

,
upi clutch kit yamaha rhino clutch noise when slowing down
,

yamaha atv wet clutch clunk noise

,
yamaha grizzly 660 clunking noise
,
yamaha grizzly 660 knocking noise at idle?
,
yamaha rhino 660 primary clutch making noise
,

yamaha rhino clutch knocking

,
yamaha rhino makes clunking noise when reving down
Click on a term to search our sites for related topics.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 09:15 AM.


RhinoForums.net is not associated with Yamaha in any way. We are an enthusiast site dedicated to the Yamaha Rhino. Our goal is to offer a place for Yamaha Rhino owners to discuss rides, events, mods, maintenance, purchasing, etc and offer help and assistance.