2008 rhino 450 idle issues - Yamaha Rhino Forum - Rhino Forums.net
Engine For discussion of engine performance, and maintenance

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 08-03-2009, 11:55 AM Thread Starter
Spectator
 
Join Date: Aug 2009
Posts: 1
2008 rhino 450 idle issues

Went to ride my rhino this weekend. Pulled the choke out and it started right away. However after a few seconds it died. I started it again this time stepping on the gas pedal. I reved the motor up a few times and when I let off the gas it died again. It will run as long as I give it gas but it won't idle. It ran fine the last time I rode it which was two months ago. Any suggestions?????

Thanks,

Ryan
RyanDicharry is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Yamaha Rhino Forum - Rhino Forums.net > Technical > Engine

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Rhino Forum - Rhino Forums.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome